On Thu, Oct 9, 2008 at 12:00 PM, hel-o <[EMAIL PROTECTED]> wrote:
>
> Hi,
>
> LDAP is enabled
> here is my configuration -> this one works in the windows environment

You are right, if you had ldap=0 you would get "LDAP authentication
failed: LDAP not activ" in the debug log.

I don't see how there could be any difference between linux and
windows environment for LDAP authentication that makes LDAP fail on
linux...

I just comited a version that should give you a more detailed log, can
you download and try it ?

>
> #-------------------------------------------------------------------------------------
> # LDAP
> #-------------------------------------------------------------------------------------
>
> #-# new LDAP authentication service
> xwiki.authentication.authclass=com.xpn.xwiki.user.impl.LDAP.XWikiLDAPAuthServiceImpl
>
> #-# Turn LDAP authentication on - otherwise only XWiki authentication
> #-# 0: disable
> #-# 1: enable
> xwiki.authentication.ldap=1
>
> #-# LDAP Server (Active Directory, eDirectory, OpenLDAP, etc.)
> xwiki.authentication.ldap.server=<SERVER>.<DOMAIN>
> xwiki.authentication.ldap.port=389
>
> #-# LDAP login, empty = anonymous access, otherwise specify full dn
> #-# {0} is replaced with the username, {1} with the password
> xwiki.authentication.ldap.bind_DN=<DOMAIN>\\{0}
> xwiki.authentication.ldap.bind_pass={1}
>
> #-# Force to check password after LDAP connection
> #-# 0: disable
> #-# 1: enable
> xwiki.authentication.ldap.validate_password=0
>
> #-# only members of the following group will be verified in the LDAP
> #-# otherwise only users that are found after searching starting from the
> base_DN
> #
> xwiki.authentication.ldap.user_group=cn=developers,ou=groups,o=MegaNova,c=US
>
> #-# [Since 1.5RC1, XWikiLDAPAuthServiceImpl]
> #-# only users not member of the following group can autheticate
> # xwiki.authentication.ldap.exclude_group=cn=admin,ou=groups,o=MegaNova,c=US
>
> #-# base DN for searches
> xwiki.authentication.ldap.base_DN=dc=<DOMAIN>
>
> #-# Specifies the LDAP attribute containing the identifier to be used as the
> XWiki name (default=cn)
> xwiki.authentication.ldap.UID_attr=sAMAccountName
>
> #-# [Since 1.5M1, XWikiLDAPAuthServiceImpl]
> #-# Specifies the LDAP attribute containing the password to be used "when
> xwiki.authentication.ldap.validate_password" is set to 1
> # xwiki.authentication.ldap.password_field=userPassword
>
> #-# [Since 1.5M1, XWikiLDAPAuthServiceImpl]
> #-# The potential LDAP groups classes. Separated by commas.
> #
> xwiki.authentication.ldap.group_classes=group,groupOfNames,groupOfUniqueNames,dynamicGroup,dynamicGroupAux,groupWiseDistributionList
>
> #-# [Since 1.5M1, XWikiLDAPAuthServiceImpl]
> #-# The potential names of the LDAP groups fields containings the members.
> Separated by commas.
> # xwiki.authentication.ldap.group_memberfields=member,uniqueMember
>
> #-# retrieve the following fields from LDAP and store them in the XWiki user
> object (xwiki-attribute=ldap-attribute)
> #-# ldap_dn=dn  -- dn is set by class, caches dn in XWiki.user object for
> faster access
> xwiki.authentication.ldap.fields_mapping=last_name=sn,first_name=givenName,fullname=fullName,email=mail,ldap_dn=dn
>
> #-# [Since 1.3M2, XWikiLDAPAuthServiceImpl]
> #-# on every login update the mapped attributes from LDAP to XWiki otherwise
> this happens only once when the XWiki account is created.
> xwiki.authentication.ldap.update_user=1
>
> #-# [Since 1.3M2, XWikiLDAPAuthServiceImpl]
> #-# mapps XWiki groups to LDAP groups, separator is "|"
> #
> xwiki.authentication.ldap.group_mapping=XWiki.XWikiAdminGroup=cn=AdminRole,ou=groups,o=MegaNova,c=US|\
> #
> XWiki.Organisation=cn=testers,ou=groups,o=MegaNova,c=US
>
> #-# [Since 1.3M2, XWikiLDAPAuthServiceImpl]
> #-# time in s after which the list of members in a group is refreshed from
> LDAP (default=3600*6)
> # xwiki.authentication.ldap.groupcache_expiration=21800
>
> #-# [Since 1.3M2, XWikiLDAPAuthServiceImpl]
> #-# - create : synchronize group membership only when the user is first
> created
> #-# - always: synchronize on every login
> xwiki.authentication.ldap.mode_group_sync=always
>
> #-# [Since 1.3M2, XWikiLDAPAuthServiceImpl]
> #-# if ldap authentication fails for any reason, try XWiki DB authentication
> with the same credentials
> xwiki.authentication.ldap.trylocal=1
>
> #-# [Since 1.3M2, XWikiLDAPAuthServiceImpl]
> #-# SSL connection to LDAP server
> #-# 0: normal
> #-# 1: SSL
> # xwiki.authentication.ldap.ssl=0
>
> #-# [Since 1.3M2, XWikiLDAPAuthServiceImpl]
> #-# The keystore file to use in SSL connection
> # xwiki.authentication.ldap.ssl.keystore=
>
> #-# [Since 1.5M1, XWikiLDAPAuthServiceImpl]
> #-# The java secure provider used in SSL connection
> #
> xwiki.authentication.ldap.ssl.secure_provider=com.sun.net.ssl.internal.ssl.Provider
>
>
> Thomas Mortagne wrote:
>>
>> On Thu, Oct 9, 2008 at 10:55 AM, hel-o <[EMAIL PROTECTED]> wrote:
>>
>> You should have a lot more log than just that, it seems ldap is
>> disabled. Check the xwiki.authentication.ldap, it should be 1.
>>
>> Helmut
>>
>>
>
> --
> View this message in context: 
> http://n2.nabble.com/LDAP-Auth-problem-in-1.6-tp1303665p1311565.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
>
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>



-- 
Thomas Mortagne
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to