Hi Oskar,

Too bad that you couldn't get it to work. I haven't followed but you're use the 
xwiki oracle HBM mapping file right?

AFAIK several users of xwiki are using Oracle. I know for sure it used to work 
and we haven't done changes to the database mapping so it would be strange it's 
not working anymore. What's possible though is that some features don't work 
without tweaking of the hibernate mapping or minor changes to the code (for ex 
Oracle considers NULL and empty strings as the same thing AFAIR) but the 
majority of features should work fine. And for features that don't work we can 
work together to fix them.

Thanks
-Vincent

On Jan 21, 2010, at 1:23 PM, Oskar Marek Rzepinski wrote:

> Hello everybody,
> 
> now after a lot of testing I think I have to look for an another wiki. I
> have the right driver, I checked this. The configuration is also not the
> problem, all parameters are O.K. I think that we have a problem with the
> geronimo server that don't let us connect to the database.  It is really
> annoying that we won't get the xwiki running. The problem is, that for
> performance reasons we won't use any other database system or an another
> container than geronimo(tomcat). Thanks to all, who tried to help me.
> 
> 
> Best regards Oskar
> 
> 
> 2010/1/20 Alonso Isidoro Roman <alons...@gmail.com>
> 
>> 2010/1/20 Caleb James DeLisle <calebdeli...@lavabit.com>
>> 
>>> The problem is definitely that XWiki can't get at the jdbc connector so I
>>> don't
>>> think creating the database will help, also XWiki uses a complicated
>> schema
>>> so creating the tables manually is not really an option.
>>> 
>>> i think i did not suggest to create manually the schema!
>> 
>> 
>>> I would go into the WEB-INF/lib and find the jdbc connector jar you
>> added,
>>> open it with a zip program, (jar is just a special type of zip file) look
>>> inside
>>> and make sure it has the file oracle/jdbc/driver/OracleDriver.class
>>> Maybe you are using the wrong jdbc.
>>> 
>>> thats a good advice!
>> 
>> 
>>> Your persistence is admirable!
>>> 
>>> Caleb
>>> 
>>> Oskar Marek Rzepinski wrote:
>>>> Hi Alonso.
>>>> 
>>>> Thank you for all the hints. You are writing about creating table. How
>> do
>>> I
>>>> create the table? I thought, that xwiki is doing this after the right
>>>> configuration. Am I right? Or have you a simple how-to for creating the
>>>> table? I have on oracle the user xwiki with all privileges. The
>>> deployment
>>>> with the geronimo consle also worked fine. I am still thinking about
>> the
>>>> oracle if I have to do something more than creating only the user with
>>> the
>>>> right grants as it is said in the installation guide on the xwiki page.
>>>> Thanks again
>>>> 
>>>> 
>>>> regards Oskar
>>>> 
>>>> 
>>>> 2010/1/20 Alonso Isidoro Roman <alons...@gmail.com>
>>>> 
>>>>> Hi Oscar,
>>>>> i dont know about to think, only thing that i can imagine is the jar
>> is
>>> not
>>>>> ok, corrupted or something like that.
>>>>> 
>>>>> pls, try downloading again the jar, put it in /WEB-INF/lib xwiki┬┤s
>>> folder,
>>>>> create a user xwiki with proper grants (create database, create table,
>>>>> etc...), put the war into webapps jboss folder and breathe!
>>>>> 
>>>>> 
>>>>> 
>>> 
>> http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/htdocs/jdbc101040.html
>>>>> 
>>>>> sorry for not be able to help you anymore!
>>>>> 
>>>>> regards

_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to