Am 23.03.2011 15:46, schrieb Elena-Oana Tabaranu:
> Hello,
>
> You can try including the colorThemeInit template at the beginning of
> your style sheet extension:
> #template('colorThemeInit.vm')
>
> Hope this helps,
> Oana
Thanks,

that did the trick !

Andreas
> On 03/23/2011 01:13 PM, Andreas Hahn wrote:
>> Hi again,
>>
>> in my ongoing efforts in customizing the appearance of the pages of my
>> wiki I've followed the steps of the skin extension tutorial:
>> http://platform.xwiki.org/xwiki/bin/view/DevGuide/SkinExtensionsTutorial
>>
>> I've created a StyleSheetExtension and selected 'Use this extension'
>> 'Always on the wiki' and it works as expected.
>>
>> However I've started to replace fix color settings by references to the
>> themes settings
>> e.g. $theme.borderColor ... $theme.titleColor
>> and also I've checked 'Parse content' 'Yes' and disabled caching this
>> doesn't work.
>> Velocity statements seem not to be processed or I am referring to
>> invalid property names.
>> (I have been trying the ones from /templates/colorThemeInit.vm)
>>
>> What am I doing wrong here ?
>>
>> In the example the page is laoded on demand with
>> $xwiki.jsx.use("XWiki.MyFirstStylesheetExtension")
>>
>> so I would assume there should be a document named
>> "MyFirstStylesheetExtension" in XWiki space (or maybe some other space).
>> Thats not the case for my own instance of
>> XWiki.MyFirstStylesheetExtension that I've added.
>> Shouldn't I be able to find the instance as a document somewhere in the
>> spaces ?
>>
>> Thanks for your support
>>
>> Andreas
>> _______________________________________________
>> users mailing list
>> users@xwiki.org
>> http://lists.xwiki.org/mailman/listinfo/users
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>

_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to