Resending as plaintext


Hi All

Hopefully someone can help with this issue.

We are running 8.1 and some users are not able to see the “create page” button. 
This is what I am expecting:


http://pasteboard.co/6y8jirpqd.png


Instead, the user sees this:

http://pasteboard.co/6y9FK2KQT.png


So I assumed it must be a permissions issue. So I checked that the Group had 
the correct permissions to Edit (in this case I am using the Sandbox as an 
example, but it applies to all other top level pages – what were once spaces).

As you can see below, the XWikiAllGroup has View and Edit permissions and the 
user can certainly see and edit the page. But I was sure that having “Edit” 
also meant the ability to “add” pages. If “adding” is a separate permission, 
please tell me where I can find this.


http://pasteboard.co/6yZBCg4ye.png


I have also tried giving the user directly ALL the permissions and still the 
user doesn’t get the “add” button. Yet if I browse directly to 
http://xwiki.local:8080/xwiki/bin/create/Sandbox/ I get the create page and I 
can successfully create/edit/save the page.

I have also tried:

• Giving all permissions to all the groups the user is a member of
• Different combinations of different groups
• Removing permissions for all groups and just giving the user permission 
directly
• Looking through the mailing list for any reported issues (though it was a 
quick browse so I may have missed it).
• Checked that I do not have any overriding *.vm files attached to the skin 
that would cause this

The next step will be to upgrade to 8.2 to see if this resolves it, but I am 
not hopeful. Any help would be sincerely appreciated. Thanks in advance.


Any help please?



Kind regards,



Mahomed Hussein
Custodian Data Centre
Email: maho...@custodiandc.com
http://www.CustodianDC.com

_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users

Reply via email to