Hi guys,
I'm having an issue with one of my new servers where my webserver
(Nginx 1.0) will not connect to the uWSGI daemon. It's setup on a TCP
address and connecting internally.
Nginx error.log entries:
2011/05/18 16:47:30 [error] 2352#0: *11 connect() failed (111:
Connection refused) while connecting to upstream, client: 98.124.42.90,
server: , request: "GET / HTTP/1.1", upstream: "uwsgi://127.0.0.1:8123",
host: "appserver"
Telnet response:
#: telnet localhost 8123
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused
uWSGI output when running server, never any change when I send it a
connection:
#: bin/restart
*** Starting uWSGI 0.9.7.2 (32bit) on [Wed May 18 16:52:52 2011] ***
compiled with version: 4.4.3 on 18 May 2011 16:13:23
*** WARNING: you are running uWSGI without its master process manager ***
your memory page size is 4096 bytes
uwsgi socket 0 bound to TCP address localhost:8123 fd 3
Python version: 2.6.5 (r265:79063, Apr 16 2010, 13:28:26) [GCC 4.4.3]
Python main interpreter initialized at 0xa02ed10
your server socket listen backlog is limited to 100 connections
*** Operational MODE: single process ***
found a multiapp module...
main mountpoint =
WSGI application 0 (SCRIPT_NAME=) ready on interpreter 0xa02ed10
(default app)
WSGI application 1 (SCRIPT_NAME=/trac) ready on interpreter 0xa02ed10
*** uWSGI is running in multiple interpreter mode ***
spawned uWSGI worker 1 (and the only) (pid: 2570, cores: 1)
This same server config works fabulously on two other servers. No
firewall, nothing weird. Any ideas? How do I debug this?
Joshua
_______________________________________________
uWSGI mailing list
[email protected]
http://lists.unbit.it/cgi-bin/mailman/listinfo/uwsgi