https://chromiumcodereview.appspot.com/10444055/diff/16001/src/bootstrapper.cc File src/bootstrapper.cc (right):
https://chromiumcodereview.appspot.com/10444055/diff/16001/src/bootstrapper.cc#newcode1635 src/bootstrapper.cc:1635: array_function->initial_map()->CopyDropTransitions(MAYBE_SHARED); I think you mean MAY_BE_SHARED https://chromiumcodereview.appspot.com/10444055/diff/16001/src/objects.h File src/objects.h (right): https://chromiumcodereview.appspot.com/10444055/diff/16001/src/objects.h#newcode174 src/objects.h:174: enum SearchMode { Since this is specific to Descriptor Arrays, consider making it an enum inside the class, or call it something like DescriptorArraySearchMode. https://chromiumcodereview.appspot.com/10444055/diff/16001/src/objects.h#newcode183 src/objects.h:183: MAYBE_SHARED, MAY_BE_SHARED https://chromiumcodereview.appspot.com/10444055/diff/16001/src/objects.h#newcode184 src/objects.h:184: FORCE_NEW Either make this CANNOT_BE_SHARED, or, since this is behavior specific to DescriptorArrays, make it an enum that's local to the class. https://chromiumcodereview.appspot.com/10444055/ -- v8-dev mailing list [email protected] http://groups.google.com/group/v8-dev
