Quick DBCs...
https://codereview.chromium.org/14856015/diff/16001/src/hydrogen-instructions.h
File src/hydrogen-instructions.h (right):
https://codereview.chromium.org/14856015/diff/16001/src/hydrogen-instructions.h#newcode3362
src/hydrogen-instructions.h:3362: if (IsCommutative()) {
Starting with "if (!IsCommutative()) return false;" is more readable
IMHO, it follows a "comb-like" pattern. Perhaps one could fold this into
a single boolean expression, but I am not sure if this is more readable
or not.
https://codereview.chromium.org/14856015/diff/16001/src/ia32/lithium-ia32.cc
File src/ia32/lithium-ia32.cc (right):
https://codereview.chromium.org/14856015/diff/16001/src/ia32/lithium-ia32.cc#newcode1621
src/ia32/lithium-ia32.cc:1621: LInstruction* result = NULL;
Ternary aversion? Use ?:
https://codereview.chromium.org/14856015/
--
--
v8-dev mailing list
[email protected]
http://groups.google.com/group/v8-dev
---
You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email
to [email protected].
For more options, visit https://groups.google.com/groups/opt_out.