Looking good. Some comments.

https://codereview.chromium.org/19798002/diff/16001/src/hydrogen-instructions.h
File src/hydrogen-instructions.h (right):

https://codereview.chromium.org/19798002/diff/16001/src/hydrogen-instructions.h#newcode410
src/hydrogen-instructions.h:410: bool IsNoString() const {
Can we name this IsNonString, in line with IsNonPrimitive?

https://codereview.chromium.org/19798002/diff/16001/src/hydrogen-instructions.h#newcode3361
src/hydrogen-instructions.h:3361: HConstant* CopyToTruncatedInt32(Zone*
zone);
I guess you tried hard to keep this const? I'd prefer to keep it; but if
it's too hard... meh :)

https://codereview.chromium.org/19798002/diff/16001/src/hydrogen-instructions.h#newcode3362
src/hydrogen-instructions.h:3362: HConstant* CopyToTruncatedNumber(Zone*
zone);
I think the original name is fine. CopyToTruncatedInt32 doesn't handle
all cases either, and will return NULL if not possible. We could rename
both to TryCopyToTruncated* though.

On 2013/07/22 07:43:47, Jakob wrote:
This sounds more generic than it is. How about "CopyOddballToNumber"?

https://codereview.chromium.org/19798002/

--
--
v8-dev mailing list
[email protected]
http://groups.google.com/group/v8-dev
--- You received this message because you are subscribed to the Google Groups "v8-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
For more options, visit https://groups.google.com/groups/opt_out.


Reply via email to