Hello,

I encountered the Unsupported clone() error as following:

==10087==
==10087== Unsupported clone() flags: 0x104011
==10087==
==10087== The only supported clone() uses are:
==10087==  - via a threads library (LinuxThreads or NPTL)
==10087==  - via the implementation of fork or vfork
==10087==  - for the Quadrics Elan3 user-space driver
==10087==
==10087== Valgrind detected that your program requires
==10087== the following unimplemented functionality:
==10087==    Valgrind does not support general clone().
==10087== This may be because the functionality is hard to implement,
==10087== or because no reasonable program would behave this way,
==10087== or because nobody has yet needed it.  In any case, let us know at
==10087== www.valgrind.org and/or try to work around the problem, if you can.
==10087==
==10087== Valgrind has to exit now.  Sorry.  Bye!
==10087==

I manually changed syswrap-x86-linux.c with the cloneflag added in the code, 
but I still get same error. Is there any other workaround for this issue? Here 
is the code change I have for the file syswrap-x86-linux.c.

Index: 
third-party/src/valgrind/valgrind-3.4.1/coregrind/m_syswrap/syswrap-x86-linux.c
===================================================================
diff --git a/valgrind-3.4.1/coregrind/m_syswrap/syswrap-x86-linux.c 
b/valgrind-3.4.1/coregrind/m_syswrap/syswrap-x86
-linux.c
index 4838271..f5afdaf 100644
--- a/valgrind-3.4.1/coregrind/m_syswrap/syswrap-x86-linux.c
+++ b/valgrind-3.4.1/coregrind/m_syswrap/syswrap-x86-linux.c
@@ -886,6 +886,7 @@ PRE(sys_clone)
                                   || cloneflags == 0x790F00
                                   || cloneflags == 0x3D0F00
                                   || cloneflags == 0x410F00
+                                  || cloneflags == 0x104011
                                   || cloneflags == 0xF00
                                   || cloneflags == 0xF21)) {
      /* OK */

Appreciate any input on this. Thanks for the help in advance.

Regards,
Rachel


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
Valgrind-users mailing list
Valgrind-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/valgrind-users

Reply via email to