On Mon, 11 May 2026 09:23:48 GMT, Axel Boldt-Christmas <[email protected]> 
wrote:

>> VM_PrintClassLayout uses the wrong VMOp_Type.
>> 
>> Probably a copy paste error. Uses `VMOp_PrintClassHierarchy` instead of 
>> `VMOp_ClassPrintLayout`.
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> Axel Boldt-Christmas has updated the pull request with a new target base due 
> to a merge or a rebase. The incremental webrev excludes the unrelated changes 
> brought in by the merge/rebase. The pull request contains five additional 
> commits since the last revision:
> 
>  - Rename symbols to be consistent with the CMD `VM.class_print_layout`
>  - Revert "Fix the VMOp name"
>    
>    This reverts commit 617c434d8ed1ccf69e9d3aeb6d25de3fce12b09a.
>  - Merge remote-tracking branch 'upstream_valhalla/lworld' into 
> lworld-wrong-vmop-type
>  - Fix the VMOp name
>  - VM_PrintClassLayout uses the wrong VMOp_Type

Looks good.

src/hotspot/share/services/diagnosticCommand.cpp line 950:

> 948: 
> 949: ClassPrintLayoutDCmd::ClassPrintLayoutDCmd(outputStream* output, bool 
> heap) :
> 950:                                        DCmdWithParser(output, heap),

Pre-existing: The indentation here is inconsistent, but so is this file in 
general.

-------------

Marked as reviewed by jsikstro (Committer).

PR Review: 
https://git.openjdk.org/valhalla/pull/2401#pullrequestreview-4262438832
PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2401#discussion_r3217865933

Reply via email to