On Thu, 4 Jun 2026 16:47:43 GMT, Chen Liang <[email protected]> wrote:

>> For preview of the serialization implementation cleanup.
>> 
>> See the mainline diff version:
>> https://gist.github.com/a3440f2b9da5111fe20315e59ed17380
>> 
>> ---------
>> - [x] I confirm that I make this contribution in accordance with the 
>> [OpenJDK Interim AI Policy](https://openjdk.org/legal/ai).
>
> Chen Liang has updated the pull request incrementally with one additional 
> commit since the last revision:
> 
>   Rename to Deserializer

src/java.base/share/classes/java/io/ObjectStreamClass.java line 1376:

> 1374:         }
> 1375: 
> 1376:         var deserializer = 
> exec.getDeclaredAnnotation(Deserializer.class);

@liach There's a bit too much "var" usage in isDeserializer so it's hard to 
review. It is of course okay when the type is on the RHS but when there is 
nothing to hint at the type it makes it hard to read.

-------------

PR Review Comment: 
https://git.openjdk.org/valhalla/pull/2326#discussion_r3363435528

Reply via email to