> In any case I first tried creating a .qmail-root file in the
> /var/qmail/alias directory and I got a bounce error stating that
> machine.domain.com was not in locals, blah,blah,blah.  So I added the
> machine name to locals and I didn't get a bounce error, but I also
> didnt' get the email in the forwarded account.

Where did the mail end up?  What do the logs say?

> I tried editing
> .qmail-root using vdelivermail (was wondering if it needed to use
> this file for proper delivery) and still no luck.

That will not help things.

> In my testing I also noticed that no aliasing seemed to be working
> for me for the domain.com domain.  For example, I have a real user of
> [EMAIL PROTECTED], this user has a .qmail-user file in
> /usr/local/vpopmail/domains/domain directory that has a command of
> /usr/local/bin/maildrop ./jr/Maildir/mailfilter and it works fine.
> But if I
> add a .qmail-useralias file with the same directive no email is
> forwarded.

By ``real user'', I assume that you mean a vpopmail user created with
vadduser.  If you create .qmail files in a vpopmail domain directory, they
will be interpreted by qmail, not vdelivermail.  Thus a .qmail-user file
overrides the vpopmail user.  If .qmail files are not working in a vpopmail
domain directory, then that is a qmail problem, not a vpopmail problem.

> Perhaps this is a separate issue, but just trying to include all
> pertinent info.  Sorry for the long email - I think I'm just missing
> something basic here...

You are missing your log files.  They should tell you exactly what is
happening (or not happening, as the case may be).

David Phillips <[EMAIL PROTECTED]>

Reply via email to