Run a cat -e /var/qmail/users/assign .  If you're not comfortable with
showing me (or the list) your assign file, there's not much we can do to


-----Original Message-----
From: Rick Phillips [mailto:[EMAIL PROTECTED]]
Sent: Tuesday, January 14, 2003 6:17 PM
Subject: [vchkpw] qmail-newu: fatal: bad format in users/assign

I have recently upgraded from Mandrake 8.2 to 9.0.  For quite a few months I
have had a smoothly working qmail-vpopmail-ezmlm-qmailadmin set-up working.
The upgrade seemed to have caused no problems.

I have just tried to add a new domain and received the following error.  (I
have changed the domain name to ????? and the password has also been mangled
to protect the innocent.)

        [root@server bin]# ./vadddomain ???????.com 4563??
        qmail-newu: fatal: bad format in users/assign
        Error: Domain does not exist

After this error, the domain name exists in /home/vpopmail but the domain
folder itself is empty - no postmaster or any other file.

When I open the file /var/qmail/users/assign there seems to be a normal
entry as below -


There is one line a white space at the top of the file if this is

When I try to remove the domain using ./vdeldomain I get

        Error: Domain does not exist

I have tried re-installing vpopmail (5.2.1) but no change.

Where should I now look or what should I re-install.  Apart from trying to
add a domain, everything has been wonderfully trouble free.

Many thanks for your help in advance,

Rick Phillips

Reply via email to