I am running netqmail-1.05 + vpopmail 5.4.3 + qmail-scanner 1.20st +
SpamAssassin + Clamuko (ClamAV) + QmailAdmin.

I patched netqmail with the Patch
'netqmail-1.05-tls-smtpauth-20040207.patch' to get ESTMP functions.

>Is there a better way to do this? 
>AFAIK, you must run qmail-smtpd as the vpopmail user, see below for what
works for me.

Now my Problem is that if i change uid / gid to vpopmail i get a "451
tempory qq failed". So it tried with changing permissions of vchkpw and
using Qmail's uid/gid or also qscan uid/qid.

Now i could not authenticate with correct username / password through client
(SMTP). Webmail (SqWebmail) works fine.
POP3 works also fine.
In the log files (smtpd/log or qmail/log or mail) i can't find any entry
correspondending to vchkpw-smtp...

I tried for almost a whole week to find anything in faq or google... Without
success :( Any Ideas what i can do more?


M. Schmitt

My: /var/qmail/supervise/qmail-smtpd/run


QMAILDUID=`id -u qmaild`
NOFILESGID=`id -g qmaild`
#VPOPMAILUID=`id -u vpopmail`
#VCHKPWGID=`id -g vpopmail`
#QSCANUID=`id -u qscand`
#QSCANGID=`id -g qscand`

MAXSMTPD=`cat /var/qmail/control/concurrencyincoming`
LOCAL=`head -1 /var/qmail/control/me`

if [ -z "$QMAILDUID" -o -z "$NOFILESGID" -o -z "$MAXSMTPD" -o -z "$LOCAL" ];
    echo "QMAILDUID, NOFILESGID, MAXSMTPD, or LOCAL is unset in"
    echo "/var/qmail/supervise/qmail-smtpd/run"
    exit 1

if [ ! -f /var/qmail/control/rcpthosts ]; then
    echo "No /var/qmail/control/rcpthosts!"
    echo "Refusing to start SMTPD listener because it would create an Open
    exit 1


exec    /usr/local/bin/softlimit -m 30000000 \
    /usr/local/bin/tcpserver -D -R -H -v -l "$LOCAL" -x /etc/tcp.smtp.cdb -p
-c "$MAXSMTPD" \
        -u "$QMAILUID" -g "$NOFILESGID" 0 smtp \
        /usr/local/bin/recordio  /var/qmail/bin/qmail-smtpd
mail.rotkreuz-kv-konstanz.de \ 
            /home/vpopmail/bin/vchkpw /bin/true 2>&1 #EOF

Reply via email to