Ken Jones wrote:

On Thursday 08 July 2004 11:12 am, Edilmar wrote:

Ken Jones wrote:

On Thursday 08 July 2004 08:47 am, Edilmar wrote:


I have a system with netqmail 1.05 + vpopmail 5.4.0 + sqwebmail 4.0.5 +
qmailadmin 1.2.0 + clamav 0.73 + qmailscanner.

Now, I'd like to do some kind of SMTP authetication using the idea of
SMTPafterPOP, to use the vpopmail users (into
vpasswd file) to authenticate the sending of emails.

I found some patches for QMail, but I'm doubt about the functionality of
its with vpopmail users database.

I work in a school and there are other units of it that uses internet
providers with dinamic IPs. Then, all the time I need to
change /etc/tcp.smtp to add the actual IP address for the list of
external users to do SMTP relay. But I think if I will have
SMTP authentication, I may do a QMail OPEN RELAY and all will work fine.
Is this TRUE or I'm CRAZY to think
about OPEN RELAY? Is there some alternatives to do this without OPEN

Use tonix's qmail-smtp/vpopmail auth patch.
Smtp authentication is the cleanest way to go.

Ken Jones

But, with it, I will configure /etc/tcp.smtp for 0.0.0. => OPEN RELAY?

No. Just configure tcp.smtp for all static IP's you want to allow to relay without authentication, like internal servers that need an outbound mail server.

For example:,RELAYCLIENT=""



I installed the smtp-auth patch, the certificate was created fine, client Mozilla recognized this certificate,
and sending/receiving emails from LAN worked fine, but LAN IP is into /etc/tcp.smtp. Then, it's not
using authentication.

When I tried to remove LAN from /etc/tcp.smtp, to test real authentication the first message error was:

553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)
553 no valid cert for gatewaying (#5.7.1)

Then, I followed the link where it's said to change the
supervise/qmail-smtpd/run into user/group ID from QMail to VPopmail. After do this, the message
error changed to the traditional:

553 sorry, that domain isn't in my list of allowed rcpthosts (#5.7.1)

the error about gatewaying didn't occur more.

What's the problem?
Is it needed to execute the "run" script with VPopmail users/group?
What about the first problem about gatewaying?

Reply via email to