I'm attempting to configure a backup mail server on a Gentoo Linux server machine.

I've been repeating the steps I took to set up the primary server on a separate Gentoo Linux machine, but am unable to add domains to vpopmail.


Upon running vadddomain, I get this:

vmysql: error creating table 'dir_control': MySQL server has gone away
vmysql: sql error[b]: MySQL server has gone away
vmysql: sql error[3]: MySQL server has gone away
vmysql: error creating table 'limits': MySQL server has gone away
vmysql: sql error[p]: MySQL server has gone away
Error: (vadduser) can't read domain limits

The database connection parameters are correct. I can log into the database as the vpopmail user with the same password in the config file, and have complete access to the vpopmail database.

The config file has this:

localhost|0|vpopmail|[password]|vpopmail

I tried changing the host to an IP address, to see if connecting via TCP would work, but it did not.

The server listens on port 3392 instead of 3306, but that is in the my.cnf file, and I also specified that port when I tried using the IP address.

The configuration in use created /tmp/mysql.sock for Unix socket access. I did try moving this to /var/run/mysqld/mysqld.sock (with a concurrent my.cnf change in the client section), and linked it back to /tmp as well.

Each time I try to use vadddomain or vdeldomain (the latter necessary to repeat the attempt at an addition), the Aborted_connects value of the server goes up.

With the primary mail server machine, I used the default Gentoo ebuild of MySQL 4.0.x.

But with this machine, which is a production database server, the MySQL version is 4.1.1 alpha. It's a custom compile from source, with a few bug fixes that had not yet been added at the time (it was the latest version when implemented - version 4.1 features are required for the production database).

Beyond that, the only discernible differences are that the database server in question is an Opteron box running the 64-bit version of Linux, and it began life as a 2004.x installation which has been upgraded to 2005.0.

Any clues as to why vpopmail is unable to connect to this database?

Would I be better served by running a second copy of MySQL 4.0.x (the normal Gentoo ebuild) than trying to figure this out?

Reply via email to