Hi,

What version of OpenLDAP are you using?

The error message is due to a failed bind from the ldapadd. You are attempting to bind using 'cn=vpopmail111' Have you already created this entry in the directory? Is this your first time using LDAP?

-dougal


Bulent wrote:
Hello
 
I use qmail on Freebsd5.4.
I read README.ldap in /path/vpopmail5.4.6
I have installed  vpopmail5.4.6 with ldap module. 
I prepared at vldap.h in /path/vpopmail5.4.6 as following;
      #define VLDAP_SERVER "localhost"
      #define VLDAP_PORT LDAP_PORT
      #define VLDAP_USER "cn=vpopmail111, o=vpopmail"
      #define VLDAP_PASSWORD "111"
      #define VLDAP_BASEDN "o=vpopmail"
 
I started /usr/local/libexec/slapd
it worked
when I wrote "ps axf" in the server
I could below line
52625  ??  Ss     0:00.97 /usr/local/libexec/slapd
I 'm the next step.
I tried to run  below line
ldapadd -f vpopmail.ldif -x -w vpoppasswd -D'cn=vpopmail111,o=vpopmail'   in /usr/local/etc/openldap
I got an error as below
ldap_bind: Invalid credentials (49)
 
What should the folder named vpopmail.ldif be contain ?
Could you send me an example ldiff file ?
 
 
 

Reply via email to