Aleks,

these are some flags I'm using (I have smtp auth ON for all users, so disabling flag is OFF):

#disable_smtp
#disable_pop
#disable_imap

In this case, SMTP auth would be ON if line is commented (as in previous lines), OFF if line is active.

Check both your default switches in /home/vpopmail/etc/vlimits.default and in your domain .qmailadmin-limits (or in your MySQL limits).

Tonino

At 23.05 21/09/2005, you wrote:
Im not really suer what flags you are aiming for tonix. But i guess
they could be enabled/disabled?

Aleks


On 9/21/05, tonix (Antonio Nati) <[EMAIL PROTECTED]> wrote:
>
>  Sorry for the dumb question.
>
>  Are your users/domains smtp flags not disabled?
>
>  Tonino
>
>
>  At 14.38 21/09/2005, you wrote:
>
>
> Thanks Bruno, but im not that keen on the TLS support anymore. Perhaps i'll toast next time :)
>
> For now im going to figure out why i cant auth with the vpopmail/contrib/auth patch or the newest version http://www.fehcom.de/qmail/auth/qmail-smtpd-auth-057_tgz.bin .
>
>   4549 > 220 mx.domain.com ESMTP
>   4549 < EHLO [192.168.0.100]
>   4549 > 250-mx.domain.com
>   4549 > 250-PIPELINING
>   4549 > 250-8BITMIME
>   4549 > 250-SIZE 0
>   4549 > 250 AUTH LOGIN PLAIN CRAM-MD5
>   4549 < AUTH CRAM-MD5
>   4549 > 334 PDExLjExMjczMDdAbXguY29uZmlnLm5vPg==
>   4549 < YWxla3NhbmRlckBvbHNlbi5jbiBkOJlNzdmZGVkMzUzYjA1ZDZlZDU4ZGNlZQ==
>   4549 > 535 authentication failed (#5.7.1)
>   4549 < AUTH PLAIN AGFsZWtzYW5kZXJAb2xzZ4AeWY4NDRpdG8=
>   4549 > 535 authentication failed (#5.7.1)
>   4549 < AUTH LOGIN
>   4549 > 334 VXNlcmbWU6
>   4549 < YWxla3NhlckBvbHNlbi5jbg==
>   4549 > 334 UGFzc3dvcmQ6
>   4549 < eWY4NpdG8=
>   4549 > 535 authentication failed (#5.7.1)
>
>
>  Thanks!
>
>
>  On 9/21/05, Bruno Negrao <[EMAIL PROTECTED] > wrote:
>    Aleks,
>
> I also had problems when I tried to install chkuser and the auth patch in vpopmail/contrib.
>
> I discovered that Bill Shupp's qmail-toaster http://shupp.org/toaster/ already has netqmail+chkuser+auth+tls patches and I'm testing it now. On the toaster mailing list you'll find Antonio Nati and other nice guys. There is even an EMPF patch made specially for qmail-toaster, but not for netqmail.
>
> It seems to me that there's a lot of people supporting qmail-toaster. Maybe you'd like to try qmail-toaster installation instead of installing all these patches by hand (this is what I'm trying to get with qmail-toaster).
>
>   Regards,
>   bnegrao
>    ----- Original Message -----
>   From: Aleks Olsen
>   To: vchkpw@inter7.com
>   Sent: Wednesday, September 21, 2005 7:14 AM
>   Subject: Re: [vchkpw] chkuser 2.0.8b
>
>   Hi
>
>   I didnt. I missed the trailing */ on that line it seems. Thanks!
>   -
> Now, it seems the patch didnt like working with auth-jms1.4a.patch(auth patch) and/or qmail-1.03-jms1.5.patch (tls patch).
>
> I got the auth patch from the vpopmail contrib dir and tried with that, leaving the ones mentioned above out of it and then patched with the netqmail*auth*chkuser patch. I believe im not really in the need for that tls anyways for smtp transactions. Now, anyone know if there is another trick to that to make the auth work with chkuser? Qmail compiled fine > with the patches and the result at the moment is the the smtp wont auth anyone and chkuser works somewhat how it is designed to work (sweet).
>
>   220 mx.domain.com ESMTP
>   ehlo
>   250-mx.domain.com
>   250-PIPELINING
>   250-8BITMIME
>   250-SIZE 0
>   250 AUTH LOGIN PLAIN
>
>   chkuser.c
>   #include "/home/vpopmail/include/vpopmail.h"
>   #include "/home/vpopmail/include/vauth.h"
>   #include "/home/vpopmail/include/vpopmail_config.h"
>
>   /* #define CHKUSER_ENABLE_VAUTH_OPEN */
>
> /usr/local/bin/tcpserver -v -R -l "$LOCAL" -x /etc/tcp.smtp.cdb -c "$MAXSMTPD" \
>   -u "$QMAILDUID" -g "$NOFILESGID" 0 smtp \
>   /var/qmail/bin/qmail-smtpd mx.domain.com \
>   /home/vpopmail/bin/vchkpw /usr/bin/true 2>&1
>
> I undefined and defined /* #define CRAM_MD5 */ from qmail-smtpd.c, compiled fine - but no-go. Wont auth.
>
>   Anyone notice anything i might have missed out?
>
>   This hoffman patch -should- work with a vpopmail/mysql setup right?
>
>   Thanks!
>
>   /Aleksander
>
>   On 9/20/05, tonix (Antonio Nati) <[EMAIL PROTECTED]> wrote:
>    At 11.51 20/09/2005, you wrote:
>
>
> Tried to patch up a clean src of qmail-1.03. I get the same error as I get with the already patched up src.
>
>   Hope this is right.
> Yes. How did you define CHKUSER_STARTING_VARIABLE within chkuser_settings.h?
>
>   Tonino
>
>
>
>  Thanks,
>   /Aleksander
>
>   -
>   static void first_time_init (void) {
>
>     char * temp_string;
>
>   #if !defined CHKUSER_ALWAYS_ON && defined CHKUSER_STARTING_VARIABLE
>           starting_string = env_get (CHKUSER_STARTING_VARIABLE);
>           if (starting_string) {
>                    if (strcasecmp(starting_string, "ALWAYS") == 0) {
>                            starting_value = 1;
>                    } else if (strcasecmp(starting_string, "DOMAIN") == 0) {
>                            starting_value = 0;
>                    }
>           } else {
>                    starting_string = "";
>           }
>   #endif
>
>   -
>
>   ./load qmail-qmtpd rcpthosts.o control.o constmap.o \
>   received.o date822fmt.o now.o qmail.o cdb.a fd.a wait.a \
>   datetime.a open.a getln.a sig.a case.a env.a stralloc.a \
>   alloc.a substdio.a error.a str.a fs.a auto_qmail.o
>   ./compile qmail-smtpd.c
>   qmail-smtpd.c: In function `main':
>   qmail-smtpd.c:1021: warning: return type of `main' is not `int'
>   ./compile spf.c
>   ./compile base64.c
>   ./compile chkuser.c
>   chkuser.c: In function `first_time_init':
>   chkuser.c:425: error: syntax error before '/' token
>   make: *** [chkuser.o] Error 1
>
>
> On 9/20/05, tonix (Antonio Nati) <[EMAIL PROTECTED]> wrote: At 11.26 20/09/2005, you wrote:
>     Hi,
> Trying to patch up an already auth+tls+spf patched qmail-smtpd and seems i hit a rock and hoping for some guidance. > I followed the manual patch guide at http://www.interazioni.it/opensource/chkuser/documentation/installation/manual.html and think I somewhat fit all the pices in the right places. When i now try to compile it I get this: > make ./compile chkuser.c chkuser.c: In function `first_time_init': chkuser.c:425: error: syntax error before '/' token make: *** [chkuser.o] Error 1 > I have not changed anything directly within the .c file Can you pls post ten lines of code surrounding the error?
>   Tonino
>
>
>
>     Anyone got a clue?
>      Thanks!
>      /Aleksander
>
>
>


Reply via email to