What does chkuser log say about passing messages?


[EMAIL PROTECTED] ha scritto:
I patched a fresh netqmail distribution with chkuser 2.09.

My chkuser_settings.h file can be seen here:

I had previously installed vpopmail 5.4.15, and it has been
working fine.

Building and installing netqmail with the chkuser patch was
successful. When I run /var/qmail/bin/qmail-smtpd as root,
I get expected results, e.g.:
'250 ok' for valid addresses, and
'550 5.1.1 sorry, no mailbox here by that name (chkuser)' for bad ones.

However, via SMTP, chkuser seems to not run at all. I see no
chkuser messages in any logfiles. Mail sent from gmail to bad
addresses on my server is accepted, then later bounced back.

I use the LWQ setup for qmail, which means my
/var/qmail/supervise/qmail-smtpd/run  script looked like:


QMAILDUID=`id -u qmaild`
NOFILESGID=`id -g qmaild`
MAXSMTPD=`cat /var/qmail/control/concurrencyincoming`
LOCAL=`head -1 /var/qmail/control/me`


exec /usr/local/bin/softlimit -m 25165824 \
/usr/local/bin/tcpserver -v -R -l "$LOCAL" -x /etc/tcp.smtp.cdb -c "$MAXSMTPD" \ -u "$QMAILDUID" -g "$NOFILESGID" 0 smtp /var/qmail/bin/qmail-smtpd 2>&1

I have since gathered that qmail-smtpd needs to run as vpopmail for
chkuser rather than qmail-smtpd to run properly, so I tried this line
instead of the former one:

exec /usr/local/bin/softlimit -m 25165824 \
/usr/local/bin/tcpserver -v -R -l "$LOCAL" -x /etc/tcp.smtp.cdb -c "$MAXSMTPD" \ -u "$VPOPMAILUID" -g "$VPOPMAILGID" 0 smtp /var/qmail/bin/qmail-smtpd 2>&1

This does indeed spawn qmail-smtpd as UID vpopmail, but it doesn't
fix the problem that chkuser doesn't seem to work for inbound mail.
Here is `ps` output, in case it is useful:
SHELL# ps auxw | grep qmail-smtp
root 22851 0.0 0.0 1412 84 ? S 2006 0:58 supervise qmail-smtpd vpopmail 8176 0.0 0.0 1608 496 ? S 18:06 0:00 /usr/local/bin/tcpserver -v -R -l MY.HOSTNAME.HERE -x /etc/tcp.smtp.cdb -c 30 -u 89 -g 89 0 smtp /var/qmail/bin/qmail-smtpd vpopmail 8465 0.0 0.0 1892 560 ? S 18:06 0:00 /var/qmail/bin/qmail-smtpd root 10049 0.0 0.3 6736 3144 pts/4 S+ 18:15 0:00 vi /var/qmail/supervise/qmail-smtpd/run vpopmail 11614 0.0 0.0 1760 364 ? S 18:29 0:00 /var/qmail/bin/qmail-smtpd root 11619 0.0 0.0 2036 660 pts/2 R+ 18:29 0:00 grep qmail-smtp

Fortunately, mail delivery to vpopmail mailboxes still works, so
my server is not broken at the moment. But I'd sure like to get
chkuser working.

Note: chkuser still works fine when I run qmail-smtpd locally as root,
from the command line.


[EMAIL PROTECTED] Interazioni di Antonio Nati http://www.interazioni.it [EMAIL PROTECTED] ------------------------------------------------------------


Reply via email to