Hash: SHA1

Wouter van der Schagt wrote:
> I found a bug with long domain names which crashes with a segmentation
> fault when the vusaged is started. We have 1 client with a domainname of
> 57 characters and although it is not the domain name listed below, it
> produces the same result. I believe vpopmail supports domainnames upto
> 63 characters? Or am I wrong?

Is this in 5.5?  What are the steps to reproduce?  I added the domain as
you did above, and my vusaged binary from trunk is running as expected,
returning data for the long domain name.

> Program received signal SIGSEGV, Segmentation fault.
> [Switching to Thread 0xb2bb9b90 (LWP 29861)]
> 0xb7e656c1 in mysql_free_result () from /usr/lib/libmysqlclient.so.15
> (gdb) bt
> #0  0xb7e656c1 in mysql_free_result () from /usr/lib/libmysqlclient.so.15
> #1  0x08059079 in vauth_getall (domain=0x8066afe
> "12345678901234567890123456789012345678901234567890123456.nl", first=1,
>    sortit=1) at vauth.c:737

This would seem to indicate that the issue occurred somewhere in vpopmail's
vauth_getall call, or in MySQL itself.

Can you post your vusaged.conf, configure options for the main tree,
and configure options for the MySQL module?

> I am guessing that a buffer size is too small. Increasing the
> SQL_BUFF_SIZE in vauth.c to 4096 seems to work, to the extend it throws
> the same error message later:

I'm not sure the buffer size is really a problem here.  It's set at 2048, which
is plenty to handle even the longest domains and usernames.

Something else is happening.  What's the last entry in your ChangeLog for the
version you're running?  This will help me identify any source changes you may
not have since you are most likely not running the trunk.
- --
    Matt Brookings <m...@inter7.com>       GnuPG Key FAE0672C
    Software developer                     Systems technician
    Inter7 Internet Technologies, Inc.     (815)776-9465
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Reply via email to