QmailAdmin will update lastauth (as least the file in the user's directory) as 
well.  I know that on my current system, pop3 and pop3s update the file (using 
qmail's POP server) but IMAP does not (using dovecot).


On Apr 11, 2013, at 1:47 PM, Charles Sprickman wrote:

> It's been some time since I've had to dig into any vpopmail issues as we have 
> a box that's been "frozen in time" for years.  It's quite the frankenbox at 
> this point and I'll be having to get myself up to speed in the coming months 
> to deal with a move to new hardware, moving to dovecot from courier, and 
> fronting the whole qmail mess with postfix.
> So I decided to start small and verify I can still rebuild the current 
> vpopmail version we run (5.4.7) in a VM and alter a few options.
> I opted to enable the "last login" function.  It was turned off long ago to 
> alleviate some db load, but that's no longer an issue for us.  I've rebuilt 
> 5.4.7 with "--enable-auth-logging" but I'm not seeing all logins show up in 
> the "lastauth" table.  We use courier (4.0.6) and authdaemond (0.58) with 
> vpopmail auth enabled.
> In my testing, I tried a pop3, pop3s, imap, and imaps login and found no 
> errors logged and no logins show up in the lastauth table.  To complicate 
> matters, I do see a handful of users showing up in the table, but I can't 
> find any common criteria here - some of these users are pop, some are imap.
> I feel like I've probably forgotten some piece of this puzzle, any hints?  
> How can I debug why the logins are not being logged?
> Thanks,
> Charles


Reply via email to