Hash: SHA1

It sounds like you have an older version of libmcrypt (2.4.0) already 
installed on your system.  What does 'which libmcrypt-config' return?  The one 
you installed should be at /usr/local/bin/libmcrypt-config (assuming you 
didn't pass a '--prefix' option to configure for libmcrypt).  If it returns 
something other than that, try running 'export 
LIBMCRYPT_CONFIG=/usr/local/bin/libmcrypt-config' and then run configure for 
mcrypt again.  

If you do have an older version of libmcrypt installed, you can find out which 
package owns it by running

rpm -qf `which libmcrypt-config`

(note the use of backticks)

If you want some more interactive help on this, feel free to join our IRC 
channel on freenode: #asfvcl


On Monday February 14, 2011, Alexander Patterson wrote:
> Hello,
> I'm having a few issues with a new install of VCL 2.2
> I am using Red Hat Enterprise Linux Server release 5.6 (Tikanga)
> yum install httpd mod_ssl php-gd php-mcrypt php-mysql php-xml
> php-xmlrpc php-ldap
> -yum php-mcrypt ins't working or being found in 5.6 in Red Hat, so I
> have to set it up manuailly. I'm getting the errors in my log
> Testing for required php extensions ...
>     * Missing these extensiosn: mcrypt. Depending on the extension,
> some or all of VCL will not work.
> Testing mcrypt ...
>     * mcrypt extension missing
> Here is what I did
> 1) Install libmcrypt (2.5.x or better)
> http://mcrypt.hellug.gr/lib/index.html I installed 2.5.8
> -download and uncompress: tar z -xvf xxx.tar.gz
> -cd into libmcrypt dir and type: ./configure
> -when configure is done type: make
> -when make is done type: make install
> This worked just fine..
> 2) Add the library dir to /etc/ld.so.conf
> -edit /etc/ld.so.conf and add: /usr/local/lib
> -save file and then type the command: ldconfig
> I can't run the ldconfig command but I added the options.
> Install latest version of mcrypt (2.6.x or better)
> http://mcrypt.hellug.gr/mcrypt/index.html
> I installed 2.6.8
> -download and uncompress: tar z -xvf xxx.tar.gz
> -cd into mcrypt dir and type: ./configure
> I then get this error. during the configure : Is there a different
> version that I should be using.
> *** 'libmcrypt-config --version' returned 2.4.0, but LIBMCRYPT (2.5.8)
> *** was found! If libmcrypt-config was correct, then it is best
> *** to remove the old version of LIBMCRYPT. You may also be able to
> fix the error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
> *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
> *** required on your system.
> *** If libmcrypt-config was wrong, set the environment variable
> LIBMCRYPT_CONFIG *** to point to the correct copy of libmcrypt-config, and
> remove the file config.cache
> *** before re-running configure
> configure: error: *** libmcrypt was not found
> [root@vclman01 mcrypt-2.6.8]#
> So to fix this issue I went out and got the libmcrypt 2.5.7 even
> older. Same error
> and I am still getting the same error.
> What is the correct versions that I need to install.  I can't find a
> libmcypt newer then 2.5.8
- -- 
- -------------------------------
Josh Thompson
VCL Developer
North Carolina State University

my GPG/PGP key can be found at pgp.mit.edu
Version: GnuPG v2.0.16 (GNU/Linux)


Reply via email to