My VDR with utf-8 is working marvelously, except for a small cosmetic
problem. The non-7-bit characters are not shown correctly on my LCD.

The LCD expects characters (i.e. it is no a graphics-LCD, or at least
the kernel module isn't), in a certain character set (iso-8859-15
probably but I can't be actually sure, something very similar though).
The vdr-lcdproc outputs characters in utf-8 (since I want to use
utf-8). So, a utf-8 to iso-8859-15 conversion is required in the chain
VDR-lcdproc-LCDd-/dev/lcd0. Currently none of the aforementioned can
do the conversion.

I can do the wollowing:

'echo ä | iconv -f utf-8 -t iso8859-15 > /dev/lcd0'

To show a real "ä" on my LCD. So, I tried the following workaround on my box:

- mkfifo fakelcd
- tail fakelcd | iconv -f utf-8 -t iso8859-15 > /dev/lcd0
- Point LCDd to fakelcd

(this is as I recall I tried it, it was some weeks ago when I did the
actual tests)

The above would work otherwise, but iconv doesn't "tail" - i.e. it
waits for EOF (or something). I could do 'cat somefile > fakelcd',
with somefile containing utf-8 characters and it was shown, but that
won't work with VDR. Any other suggestions?

Also, in your opinion, which one in the chain
VDR-lcdproc-LCDd-/dev/lcd0 should be responsible of the conversion of
the character set? I'm asking so I know which programs author should I
point my whine to =)

-  Ville

vdr mailing list

Reply via email to