VDR User wrote:
> On Sat, May 31, 2008 at 10:00 PM, Simon Baxter <[EMAIL PROTECTED]> wrote:
>> Hi.  I had the same problem originally.  Can't remember what I did, and in
>> what order - but this should help....
>> [EMAIL PROTECTED] dvd]# pwd
>> /root/vdr-1.6.0/PLUGINS/src/dvd
>> [EMAIL PROTECTED] dvd]# grep stdint.h *
>> ca52.c:#include <stdint.h>
>> tools-dvd.h:#include <stdint.h>
>> [EMAIL PROTECTED] dvd]# grep inttypes.h *
>> ca52.h:#include <inttypes.h>
>> dvdspu.c:#include <inttypes.h>
>> dvdspu.h:#include <inttypes.h>
>> tools-dvd.h:#include <inttypes.h>

I have those too, but they were already there. I'm using a CVS snapshot
of dvd plugin from 2007-10-30.

> I added #include <stdint.h> and #include <inttypes.h> to the top of
> all those files and still got the same error.  Which libdvdread-dev
> version are you using?  I've got:
> ii  libdvdread-dev               0.9.7-10                     library
> for reading DVDs (development)

I have the same.
With libdvdnav 0.1.10 works directly, with 4.1.1 I need the below
define, with 4.1.2 I need the below define and a patch to libdvdnav:

> Btw, I also tried adding -D__STDC_LIMIT_MACROS to compiler parameters
> as Anssi suggested but that had no affect as well.

Anssi Hannula

Anssi Hannula

vdr mailing list

Reply via email to