The sky plugin does not compile any more, because it uses PID_MASK_HI which got renamed to TS_PID_MASK_HI. Patch is attached. A similar problem strikes for streamdev.


Cheers,

Udo

--- vdr-1.7.1-old/PLUGINS/src/sky/sky.c 2008-09-07 13:34:53.000000000 +0200
+++ vdr-1.7.1/PLUGINS/src/sky/sky.c     2008-09-07 13:38:23.000000000 +0200
@@ -160,12 +160,12 @@
      Data = tsBuffer->Get();
      if (Data) {
         // insert the actual PIDs:
-        int Pid = (((uint16_t)Data[1] & PID_MASK_HI) << 8) | Data[2];
+        int Pid = (((uint16_t)Data[1] & TS_PID_MASK_HI) << 8) | Data[2];
         if (Pid == DUMMYAPID)
            Pid = apid;
         else if (Pid == DUMMYVPID)
            Pid = vpid;
-        Data[1] = ((Pid >> 8) & 0xFF) | (Data[1] & ~PID_MASK_HI);
+        Data[1] = ((Pid >> 8) & 0xFF) | (Data[1] & ~TS_PID_MASK_HI);
         Data[2] = Pid & 0xFF;
         }
      return true;
_______________________________________________
vdr mailing list
vdr@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to