On Thu, Oct 31, 2013 at 07:07:08AM -0400, Mooli Tayer wrote:
> While building master on a rhel-6.4 according to instructions at ovirt.org [1]
> I encountered several issues:
> 1.)This line:
> yum install --enablerepo=ovirt-beta x86_64/* noarch/vdsm-xml* noarch/vdsm-cli
> Is missing:  noarch/vdsm-python-zombiereaper*
> Is that correct? I'll fix it if so
> 2.) we need the gluster 3.4.1 repos which we get, but we also get 3.4.0 (from 
> resources.ovirt.org)
> so after following instructions we end up with glusterfs-epel.repo.1 with 
> 3.4.1 and glusterfs-epel.repo with 3.4.0
> Is this a problem? are newer versions considered?

Thanks for fixing the wiki for 1 and 2.

> 3.)  selinux-policy-targeted >= 3.7.19-195.el6.13 is missing (known issue I 
> believe)
> It also can be found on-line, can we still build somehow?

This package has been released by Red Hat recently, coming Centos way
anytime soon. You can take my http://gerrit.ovirt.org/#/c/20313/ hack if
you do not want to use --force when installing vdsm.

> 4.) this issue, which I don't get:
> Error: Package: libvirt-lock-sanlock-0.10.2-18.el6.x86_64 (RHEL-6.4-optional)
>            Requires: libvirt = 0.10.2-18.el6
>            Available: libvirt-0.10.2-18.el6.x86_64 (RHEL-6.4)
>                libvirt = 0.10.2-18.el6
>            Installing: libvirt-0.10.2-18.el6_4.14.x86_64 (RHEL-6-updates)
>                libvirt = 0.10.2-18.el6_4.14

Red Hat ships libvirt-lock-sanlock in the EL "optional" channel, not in
the basic "platform" one. You have an old libvirt-lock-sanlock installed on your
host (from "optional"), and a newer libvirt is available on your
"platform" channel. However, their versions must match. So you can
either wait for a newer libvirt-lock-sanlock, or ignore the error and
keep the older libvirt.

vdsm-devel mailing list

Reply via email to