Am Montag, 29. Januar 2007 schrieb The Watermelon:
> On 1/29/07, Dennis Schridde <[EMAIL PROTECTED]> wrote:
> > Am Sonntag, 28. Januar 2007 schrieb Dennis Schridde:
> > > Am Sonntag, 28. Januar 2007 schrieb The Watermelon:
> >
> > Ugly typo:
> > > Some notes:
> > > - Please
> >
> > DONT
> >
> > > create patches which just comment out something. Remove it or
> > > don't remove it. We can allways revert using SVN and in the patch we
> > > see what you changed, too, so I see really no point to add huge amounts
> > > of commented out code.
> Removed commented-out lines and move a glMatrixPop and a glMatrixPush out
> of 'for loop' in pie_DrawRemainingTransShapes in piedraw.c(glLoadIdentity
> does top stack replacement,no need to do glMatrixPop and glMatrixPush
> inside 'for loop' imo).

display3d.c @@ -1607,9 +1607,9 @@
p[0].x = tileScreenInfo[i+0][j+0].sx; p[0].y = tileScreenInfo[i+0][j+0].sy; 
p[0].z = tileScreenInfo[i+0][j+0].sz;
be replaced with
p[0] = tileScreenInfo[i+0][j+0];
or is that not possible because of different data types?

Similar things are done in several other locations, too.

Maybe some more types can get their x,y,z and u,v coordinates replaced by 
Vector3 and Vector2 ?

Another suggestion would also be to replace "pos" with "position".
But I don't exactly know if that's a correct naming anyway. Is the x,y,z in a 
vertex a "position"? This is nothing really important. The name "position" 
doesn't seem to fit for me, but it may very well be that I am totally wrong.

Can iVertex and PIEVERTEX be merged? It seems to me that they are mostly the 
same. (What does the g field in iVertex mean?)

There is also a PIEVECTORF, can't that be replaced by Vector3, too?

And iVectorf? Replace it with Vector3d? Ohwowow... I just saw that you 
replaced iVectorf with Vector3f... That doesn't look good, since iVectorf 
used doubles, while Vector3f is about floats...

Typedefinitions should go with the SDL types, if they are providing an API, 
IMO. Makes it more obvious what they are representing and in the long run I 
wanted to replace all Win types with SDL types anyway.

iVertex is missing a space in the list. Looks better if it gets it. ;)
(Yes, this is a bit nitpicking, but I would forget to change it myself before 
applying or after someone else applied it.)

The name MakeVector3fInt should be improved IMO... Vector3_Float2Int maybe? Is 
there a commonly used name for such conversions?


Attachment: pgpb5dXdLxWV8.pgp
Description: PGP signature

Warzone-dev mailing list

Reply via email to