On 1/29/07, Dennis Schridde <[EMAIL PROTECTED]> wrote:

display3d.c @@ -1607,9 +1607,9 @@
Can't
p[0].x = tileScreenInfo[i+0][j+0].sx; p[0].y =
tileScreenInfo[i+0][j+0].sy;
p[0].z = tileScreenInfo[i+0][j+0].sz;
be replaced with
p[0] = tileScreenInfo[i+0][j+0];
or is that not possible because of different data types?

tileScreenInfo is a SVMESH while p is a Vector3f...

Similar things are done in several other locations, too.

Maybe some more types can get their x,y,z and u,v coordinates replaced by
Vector3 and Vector2 ?

Another suggestion would also be to replace "pos" with "position".
But I don't exactly know if that's a correct naming anyway. Is the x,y,z
in a
vertex a "position"? This is nothing really important. The name "position"
doesn't seem to fit for me, but it may very well be that I am totally
wrong.

Can iVertex and PIEVERTEX be merged? It seems to me that they are mostly
the
same. (What does the g field in iVertex mean?)

I dont know what the 'g' field is in iVertex either...havent looked at
functions that use it...seems to be some color byte...

There is also a PIEVECTORF, can't that be replaced by Vector3, too?


yes i think it can be safely replaced by Vector3f too...

And iVectorf? Replace it with Vector3d? Ohwowow... I just saw that you
replaced iVectorf with Vector3f... That doesn't look good, since iVectorf
used doubles, while Vector3f is about floats...


iVectorf is useless because it will eventually get abused to integer in
imdload.c,which is the only instance of iVectorf iirc.

I am currently looking into the possibility to change all those x,y,z in
PIEVERTEX and other pie structs to float from sint32 to increase the
precision of pie point coords like someone suggested in forum,and change
imdload function to use '%5.5f'(just a random number) to sscanf imd points
in pie files,though all exist pie files will need to be changed to cope with
such changes i think...

I will change it to Vector3d for better readability anyways.

Typedefinitions should go with the SDL types, if they are providing an API,
IMO. Makes it more obvious what they are representing and in the long run
I
wanted to replace all Win types with SDL types anyway.

iVertex is missing a space in the list. Looks better if it gets it. ;)
(Yes, this is a bit nitpicking, but I would forget to change it myself
before
applying or after someone else applied it.)

The name MakeVector3fInt should be improved IMO... Vector3_Float2Int
maybe? Is
there a commonly used name for such conversions?

--Dennis

not sure about the naming stuff
_______________________________________________
Warzone-dev mailing list
Warzone-dev@gna.org
https://mail.gna.org/listinfo/warzone-dev

Reply via email to