It worked after i have tried the following:

$ie.frame(:id, "frameID").image(:id, /ImageID/).fire_event('onMouseover')

but now when it clicks on the menu it opens up a tiny window inside span
where I need to click a button but that does not seem to work properly :(


On Wed, Oct 8, 2008 at 9:52 AM, Natasha Ranney <[EMAIL PROTECTED]> wrote:

> Not sure. But, did you try the following:
>
> $ie.span(:id,"Id_Of_Span").link(:index,1).click
>
> *Fatema Karim <[EMAIL PROTECTED]>* wrote:
>
>
> Hi Tiffany,
> I have tried the Span with it's id but that did not work.
> On Tue, Oct 7, 2008 at 4:56 PM, Tiffany Fodor <[EMAIL PROTECTED]> wrote:
>
>>
>> Hi!
>>
>> Have you tried clicking on the span itself?
>>
>> ie.span(:text, 'SpanText').click
>>
>> -Tiffany
>>
>> On Oct 7, 3:27 pm, FM <[EMAIL PROTECTED]> wrote:
>> > Hi,
>> >
>> > I am trying to click a menu item on the webpage using it's id but it
>> > does not seem to work. Any suggestion? The menu item is contained by
>> > <span> element.
>> >
>> > Thank you.
>>
>>
>
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to