i've added the require statement to the enabled popup script itself, so 
this workaround will not be required with the next version of watir

jpweston wrote:
> Thanks for this and your explanation in the "Uninitialzied Constant"
> post.
>
> j.
>
> On Nov 12, 9:17 pm, Bret Pettichord <[EMAIL PROTECTED]> wrote:
>   
>> the solution is to add "require 'watir/ie'" to your script
>>
>> jpweston wrote:
>>     
>>> After installing WATIR 1.6.2, scripts that have the following line:
>>> require 'watir/contrib/enabled_popup' are causing the following error:
>>>       
>>> c:/ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/contrib/
>>> enabled_popup.rb:5: uninitialized constant Watir::PageContainer::Win32
>>> (NameError)
>>>    from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
>>> `gem_original_require'
>>>    from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
>>> `require'
>>>       
>>> Here is what I have at the top of my scripts:
>>>       
>>> require 'test/unit'
>>> require 'ci/reporter/rake/test_unit_loader.rb'
>>> require 'watir'
>>> require 'watir/testcase'
>>> require 'watir/contrib/enabled_popup'
>>>       
>>> class TC_sales_tests < Watir::TestCase
>>>       
>>>   include Watir
>>>       
>>> <code>
>>>       
>>> end
>>>       
>>> Can someone point me toward what I am doing wrong here?  These scripts
>>> worked with the version of 1.5 that I had installed.
>>>       
>>> Thanks.
>>>       
>>> Johnathan
>>>       
> >
>   


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to