Title: [103756] trunk/Source/WebKit/efl
Revision
103756
Author
[email protected]
Date
2011-12-27 21:13:56 -0800 (Tue, 27 Dec 2011)

Log Message

[EFL] Remove duplicate code and remove entry after freeing the matrix.
https://bugs.webkit.org/show_bug.cgi?id=75073

Patch by JungJik Lee <[email protected]> on 2011-12-27
Reviewed by Ryosuke Niwa.

Remove duplicate ewk_tile_unused_cache_freeze code.
Entry matrix should free first before removing entry in inlist,
because in eina_matrixsparce_free callback entry pointer is referenced to decrease the reference count.

* ewk/ewk_tiled_matrix.cpp:
(ewk_tile_matrix_free):

Modified Paths

Diff

Modified: trunk/Source/WebKit/efl/ChangeLog (103755 => 103756)


--- trunk/Source/WebKit/efl/ChangeLog	2011-12-28 04:08:42 UTC (rev 103755)
+++ trunk/Source/WebKit/efl/ChangeLog	2011-12-28 05:13:56 UTC (rev 103756)
@@ -1,3 +1,17 @@
+2011-12-27  JungJik Lee  <[email protected]>
+
+        [EFL] Remove duplicate code and remove entry after freeing the matrix.
+        https://bugs.webkit.org/show_bug.cgi?id=75073
+
+        Reviewed by Ryosuke Niwa.
+
+        Remove duplicate ewk_tile_unused_cache_freeze code.
+        Entry matrix should free first before removing entry in inlist,
+        because in eina_matrixsparce_free callback entry pointer is referenced to decrease the reference count.
+
+        * ewk/ewk_tiled_matrix.cpp:
+        (ewk_tile_matrix_free):
+
 2011-12-26  Ryuan Choi  <[email protected]>
 
         [EFL] Last parameter of ewk_view_scroll is always true.

Modified: trunk/Source/WebKit/efl/ewk/ewk_tiled_matrix.cpp (103755 => 103756)


--- trunk/Source/WebKit/efl/ewk/ewk_tiled_matrix.cpp	2011-12-28 04:08:42 UTC (rev 103755)
+++ trunk/Source/WebKit/efl/ewk/ewk_tiled_matrix.cpp	2011-12-28 05:13:56 UTC (rev 103756)
@@ -297,13 +297,12 @@
 #endif
 
     EINA_SAFETY_ON_NULL_RETURN(tileMatrix);
-    ewk_tile_unused_cache_freeze(tileMatrix->tilieUnusedCache);
 
     ewk_tile_unused_cache_freeze(tileMatrix->tilieUnusedCache);
     ewk_tile_matrix_invalidate(tileMatrix);
     entry = EINA_INLIST_CONTAINER_GET(tileMatrix->matrices, Ewk_Tile_Matrix_Entry);
-    tileMatrix->matrices = eina_inlist_remove(tileMatrix->matrices, (Eina_Inlist *)entry);
     eina_matrixsparse_free(entry->matrix);
+    tileMatrix->matrices = eina_inlist_remove(tileMatrix->matrices, reinterpret_cast<Eina_Inlist*>(entry));
     free(entry);
     tileMatrix->matrices = 0;
 
_______________________________________________
webkit-changes mailing list
[email protected]
http://lists.webkit.org/mailman/listinfo.cgi/webkit-changes

Reply via email to