Title: [107299] trunk/Source/WebCore
Revision
107299
Author
[email protected]
Date
2012-02-09 15:41:30 -0800 (Thu, 09 Feb 2012)

Log Message

Rename [Return] to [CustomReturn]
https://bugs.webkit.org/show_bug.cgi?id=78225

Reviewed by Adam Barth.

[Return] is used to handle custom code for a returned value.
To clarify it, this patch renames [Return] to [CustomReturn].

No tests. No change in behavior.

* bindings/scripts/CodeGeneratorCPP.pm:
(GenerateImplementation):
* bindings/scripts/CodeGeneratorGObject.pm:
(GenerateFunction):
* bindings/scripts/CodeGeneratorObjC.pm:
(GenerateImplementation):
* dom/Node.idl:

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (107298 => 107299)


--- trunk/Source/WebCore/ChangeLog	2012-02-09 23:33:13 UTC (rev 107298)
+++ trunk/Source/WebCore/ChangeLog	2012-02-09 23:41:30 UTC (rev 107299)
@@ -1,3 +1,23 @@
+2012-02-09  Kentaro Hara  <[email protected]>
+
+        Rename [Return] to [CustomReturn]
+        https://bugs.webkit.org/show_bug.cgi?id=78225
+
+        Reviewed by Adam Barth.
+
+        [Return] is used to handle custom code for a returned value.
+        To clarify it, this patch renames [Return] to [CustomReturn].
+
+        No tests. No change in behavior.
+
+        * bindings/scripts/CodeGeneratorCPP.pm:
+        (GenerateImplementation):
+        * bindings/scripts/CodeGeneratorGObject.pm:
+        (GenerateFunction):
+        * bindings/scripts/CodeGeneratorObjC.pm:
+        (GenerateImplementation):
+        * dom/Node.idl:
+
 2012-02-09  Levi Weintraub  <[email protected]>
 
         Add roundedIntPoint method for LayoutPoints

Modified: trunk/Source/WebCore/bindings/scripts/CodeGeneratorCPP.pm (107298 => 107299)


--- trunk/Source/WebCore/bindings/scripts/CodeGeneratorCPP.pm	2012-02-09 23:33:13 UTC (rev 107298)
+++ trunk/Source/WebCore/bindings/scripts/CodeGeneratorCPP.pm	2012-02-09 23:41:30 UTC (rev 107299)
@@ -807,7 +807,7 @@
                 my $implGetter = GetCPPTypeGetter($paramName, $idlType);
 
                 push(@parameterNames, $implGetter);
-                $needsCustom{"NodeToReturn"} = $paramName if $param->extendedAttributes->{"Return"};
+                $needsCustom{"NodeToReturn"} = $paramName if $param->extendedAttributes->{"CustomReturn"};
 
                 unless ($codeGenerator->IsPrimitiveType($idlType) or $codeGenerator->IsStringType($idlType)) {
                     push(@needsAssert, "    ASSERT($paramName);\n");

Modified: trunk/Source/WebCore/bindings/scripts/CodeGeneratorGObject.pm (107298 => 107299)


--- trunk/Source/WebCore/bindings/scripts/CodeGeneratorGObject.pm	2012-02-09 23:33:13 UTC (rev 107298)
+++ trunk/Source/WebCore/bindings/scripts/CodeGeneratorGObject.pm	2012-02-09 23:41:30 UTC (rev 107299)
@@ -868,7 +868,7 @@
 
             push(@cBody, "    }\n");
         }
-        $returnParamName = "converted_".$paramName if $param->extendedAttributes->{"Return"};
+        $returnParamName = "converted_".$paramName if $param->extendedAttributes->{"CustomReturn"};
     }
 
     my $assign = "";

Modified: trunk/Source/WebCore/bindings/scripts/CodeGeneratorObjC.pm (107298 => 107299)


--- trunk/Source/WebCore/bindings/scripts/CodeGeneratorObjC.pm	2012-02-09 23:33:13 UTC (rev 107298)
+++ trunk/Source/WebCore/bindings/scripts/CodeGeneratorObjC.pm	2012-02-09 23:41:30 UTC (rev 107299)
@@ -1495,7 +1495,7 @@
                 $needsCustom{"NodeFilter"} = $paramName if $idlType eq "NodeFilter";
                 $needsCustom{"EventListener"} = $paramName if $idlType eq "EventListener";
                 $needsCustom{"EventTarget"} = $paramName if $idlType eq "EventTarget";
-                $needsCustom{"NodeToReturn"} = $paramName if $param->extendedAttributes->{"Return"};
+                $needsCustom{"NodeToReturn"} = $paramName if $param->extendedAttributes->{"CustomReturn"};
 
                 unless ($codeGenerator->IsPrimitiveType($idlType) or $codeGenerator->IsStringType($idlType)) {
                     push(@needsAssert, "    ASSERT($paramName);\n");

Modified: trunk/Source/WebCore/dom/Node.idl (107298 => 107299)


--- trunk/Source/WebCore/dom/Node.idl	2012-02-09 23:33:13 UTC (rev 107298)
+++ trunk/Source/WebCore/dom/Node.idl	2012-02-09 23:41:30 UTC (rev 107299)
@@ -67,15 +67,15 @@
         readonly attribute NamedNodeMap     attributes;
         readonly attribute Document         ownerDocument;
 
-        [ObjCLegacyUnnamedParameters, Custom] Node insertBefore(in [Return] Node newChild,
-                                                 in Node refChild)
+        [ObjCLegacyUnnamedParameters, Custom] Node insertBefore(in [CustomReturn] Node newChild,
+                                                                in Node refChild)
             raises(DOMException);
         [ObjCLegacyUnnamedParameters, Custom] Node replaceChild(in Node newChild,
-                                                 in [Return] Node oldChild)
+                                                                in [CustomReturn] Node oldChild)
             raises(DOMExceptionJSC);
-        [Custom] Node               removeChild(in [Return] Node oldChild)
+        [Custom] Node               removeChild(in [CustomReturn] Node oldChild)
             raises(DOMException);
-        [Custom] Node               appendChild(in [Return] Node newChild)
+        [Custom] Node               appendChild(in [CustomReturn] Node newChild)
             raises(DOMException);
 
         boolean            hasChildNodes();
_______________________________________________
webkit-changes mailing list
[email protected]
http://lists.webkit.org/mailman/listinfo.cgi/webkit-changes

Reply via email to