Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 2193fab8bc97d805cefd559ae85ac96f46c9bb88
      
https://github.com/WebKit/WebKit/commit/2193fab8bc97d805cefd559ae85ac96f46c9bb88
  Author: Alex Christensen <[email protected]>
  Date:   2026-10-01 (Thu, 01 Oct 2026)

  Changed paths:
    M Source/WebCore/page/FrameIdentifier.cpp
    M Source/WebCore/page/FrameIdentifier.h
    M Source/WebCore/platform/graphics/GraphicsLayer.h
    M Source/WebCore/platform/graphics/ca/FrameProcessIndicators.cpp
    M Source/WebCore/platform/graphics/ca/GraphicsLayerCA.cpp
    M Source/WebCore/platform/graphics/ca/GraphicsLayerCA.h
    M Source/WebCore/rendering/RenderLayerBacking.cpp

  Log Message:
  -----------
  Make frame identifier more readable in frame process border indicator
https://bugs.webkit.org/show_bug.cgi?id=325828
rdar://188834684

Reviewed by Per Arne Vollan.

A frame identifier is constructed from two uint32_t's, so printing it as a 
uint64_t
is always a lot of digits.  This makes it two small 32-bit integers, which is 
much easier
to reason about.

* Source/WebCore/platform/graphics/GraphicsLayer.h:
(WebCore::GraphicsLayer::setShowFrameProcessBorders):
(WebCore::GraphicsLayer::frameID const):
* Source/WebCore/platform/graphics/ca/FrameProcessIndicators.cpp:
(WebCore::frameIdentifierString):
(WebCore::FrameProcessIndicators::FrameProcessIndicators):
* Source/WebCore/platform/graphics/ca/GraphicsLayerCA.cpp:
(WebCore::GraphicsLayerCA::ensureStructuralLayer):
* Source/WebCore/platform/graphics/ca/GraphicsLayerCA.h:
* Source/WebCore/rendering/RenderLayerBacking.cpp:
(WebCore::RenderLayerBacking::updateDebugIndicators):
* Source/WebCore/page/FrameIdentifier.cpp:
(WebCore::frameIdentifierString):
* Source/WebCore/page/FrameIdentifier.h:

Canonical link: https://commits.webkit.org/322414@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to