Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 7145f5964001e96cde73348f45caad9641dfb4b9
https://github.com/WebKit/WebKit/commit/7145f5964001e96cde73348f45caad9641dfb4b9
Author: Sammy Gill <[email protected]>
Date: 2026-10-02 (Fri, 02 Oct 2026)
Changed paths:
M Source/WebCore/layout/formattingContexts/grid/GridItemSizingFunctions.cpp
M Source/WebCore/layout/formattingContexts/grid/GridLayoutUtils.cpp
M Source/WebCore/layout/formattingContexts/grid/GridLayoutUtils.h
M Source/WebCore/layout/integration/LayoutIntegrationUtils.cpp
M Source/WebCore/layout/integration/LayoutIntegrationUtils.h
Log Message:
-----------
[GFC] Rename inlineAxisConstraint to gridAreaInlineSize.
https://bugs.webkit.org/show_bug.cgi?id=326100
rdar://problem/189019469
Reviewed by Vitor Roriz.
inlineAxisConstraint is a fine name but in my opinion it is not as clear
as what it could be in terms of what it represents. gridAreaInlineSize
is much more specific since that is what we are using as the constraint
here so instead of trying to figure out what this constraint actually is
we can just rename the variable to be gridAreaInlineSize. If for some
reason this constraint ever needs to be something else rather than the
grid area inline size we can revisit this naming.
Canonical link: https://commits.webkit.org/322538@main
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications