Title: [179815] trunk/Source/_javascript_Core
Revision
179815
Author
[email protected]
Date
2015-02-08 18:38:47 -0800 (Sun, 08 Feb 2015)

Log Message

Encapsulate DFG::Plan's beforeFTL timestamp
https://bugs.webkit.org/show_bug.cgi?id=141360

Reviewed by Darin Adler.

Make the attribute private, it is an internal state.

Rename beforeFTL->timeBeforeFTL for readability.

* dfg/DFGPlan.cpp:
(JSC::DFG::Plan::compileInThread):
(JSC::DFG::Plan::compileInThreadImpl):
* dfg/DFGPlan.h:

Modified Paths

Diff

Modified: trunk/Source/_javascript_Core/ChangeLog (179814 => 179815)


--- trunk/Source/_javascript_Core/ChangeLog	2015-02-09 02:37:03 UTC (rev 179814)
+++ trunk/Source/_javascript_Core/ChangeLog	2015-02-09 02:38:47 UTC (rev 179815)
@@ -1,3 +1,19 @@
+2015-02-08  Benjamin Poulain  <[email protected]>
+
+        Encapsulate DFG::Plan's beforeFTL timestamp
+        https://bugs.webkit.org/show_bug.cgi?id=141360
+
+        Reviewed by Darin Adler.
+
+        Make the attribute private, it is an internal state.
+
+        Rename beforeFTL->timeBeforeFTL for readability.
+
+        * dfg/DFGPlan.cpp:
+        (JSC::DFG::Plan::compileInThread):
+        (JSC::DFG::Plan::compileInThreadImpl):
+        * dfg/DFGPlan.h:
+
 2015-02-08  Benjamin Poulain  <[email protected]>
 
         Remove DFGNode::hasArithNodeFlags()

Modified: trunk/Source/_javascript_Core/dfg/DFGPlan.cpp (179814 => 179815)


--- trunk/Source/_javascript_Core/dfg/DFGPlan.cpp	2015-02-09 02:37:03 UTC (rev 179814)
+++ trunk/Source/_javascript_Core/dfg/DFGPlan.cpp	2015-02-09 02:38:47 UTC (rev 179815)
@@ -151,7 +151,7 @@
     double before = 0;
     CString codeBlockName;
     if (reportCompileTimes()) {
-        before = currentTimeMS();
+        before = monotonicallyIncreasingTime();
         codeBlockName = toCString(*codeBlock);
     }
     
@@ -188,10 +188,10 @@
 #endif
             break;
         }
-        double now = currentTimeMS();
+        double now = monotonicallyIncreasingTime();
         dataLog("Optimized ", codeBlockName, " using ", mode, " with ", pathName, " into ", finalizer ? finalizer->codeSize() : 0, " bytes in ", now - before, " ms");
         if (path == FTLPath)
-            dataLog(" (DFG: ", beforeFTL - before, ", LLVM: ", now - beforeFTL, ")");
+            dataLog(" (DFG: ", m_timeBeforeFTL - before, ", LLVM: ", now - m_timeBeforeFTL, ")");
         dataLog(".\n");
     }
 }
@@ -384,7 +384,7 @@
         FTL::lowerDFGToLLVM(state);
         
         if (reportCompileTimes())
-            beforeFTL = currentTimeMS();
+            m_timeBeforeFTL = monotonicallyIncreasingTime();
         
         if (Options::llvmAlwaysFailsBeforeCompile()) {
             FTL::fail(state);

Modified: trunk/Source/_javascript_Core/dfg/DFGPlan.h (179814 => 179815)


--- trunk/Source/_javascript_Core/dfg/DFGPlan.h	2015-02-09 02:37:03 UTC (rev 179814)
+++ trunk/Source/_javascript_Core/dfg/DFGPlan.h	2015-02-09 02:38:47 UTC (rev 179815)
@@ -97,8 +97,6 @@
     
     bool willTryToTierUp;
 
-    double beforeFTL;
-
     enum Stage { Preparing, Compiling, Compiled, Ready, Cancelled };
     Stage stage;
 
@@ -112,6 +110,8 @@
     
     bool isStillValid();
     void reallyAdd(CommonData*);
+
+    double m_timeBeforeFTL;
 };
 
 #else // ENABLE(DFG_JIT)
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to