Title: [185302] trunk/Source/WTF
Revision
185302
Author
[email protected]
Date
2015-06-07 10:35:12 -0700 (Sun, 07 Jun 2015)

Log Message

Unifiy the definition of UNREACHABLE_FOR_PLATFORM
https://bugs.webkit.org/show_bug.cgi?id=145737

Reviewed by Anders Carlsson.

* wtf/Assertions.h:
(UNREACHABLE_FOR_PLATFORM): Use the macro for clang as well. Its expansion includes
__attribute((__noreturn__)) so the pragmas are unnecessary.

Modified Paths

Diff

Modified: trunk/Source/WTF/ChangeLog (185301 => 185302)


--- trunk/Source/WTF/ChangeLog	2015-06-07 14:42:28 UTC (rev 185301)
+++ trunk/Source/WTF/ChangeLog	2015-06-07 17:35:12 UTC (rev 185302)
@@ -1,3 +1,14 @@
+2015-06-07  Dan Bernstein  <[email protected]>
+
+        Unifiy the definition of UNREACHABLE_FOR_PLATFORM
+        https://bugs.webkit.org/show_bug.cgi?id=145737
+
+        Reviewed by Anders Carlsson.
+
+        * wtf/Assertions.h:
+        (UNREACHABLE_FOR_PLATFORM): Use the macro for clang as well. Its expansion includes
+        __attribute((__noreturn__)) so the pragmas are unnecessary.
+
 2015-06-05  Chris Dumez  <[email protected]>
 
         [WK2][iOS] Limit the number of vnodes used by the WebContent processes

Modified: trunk/Source/WTF/wtf/Assertions.h (185301 => 185302)


--- trunk/Source/WTF/wtf/Assertions.h	2015-06-07 14:42:28 UTC (rev 185301)
+++ trunk/Source/WTF/wtf/Assertions.h	2015-06-07 17:35:12 UTC (rev 185302)
@@ -372,19 +372,6 @@
 
 /* UNREACHABLE_FOR_PLATFORM */
 
-#if COMPILER(CLANG)
-// This would be a macro except that its use of #pragma works best around
-// a function. Hence it uses macro naming convention.
-#pragma clang diagnostic push
-#pragma clang diagnostic ignored "-Wmissing-noreturn"
-static inline void UNREACHABLE_FOR_PLATFORM()
-{
-    RELEASE_ASSERT_NOT_REACHED();
-}
-#pragma clang diagnostic pop
-#else
 #define UNREACHABLE_FOR_PLATFORM() RELEASE_ASSERT_NOT_REACHED()
-#endif
 
-
 #endif /* WTF_Assertions_h */
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to