Title: [185303] trunk/Source/WTF
- Revision
- 185303
- Author
- [email protected]
- Date
- 2015-06-07 10:37:37 -0700 (Sun, 07 Jun 2015)
Log Message
Reverted r185302 because it broke the build
Modified Paths
Diff
Modified: trunk/Source/WTF/ChangeLog (185302 => 185303)
--- trunk/Source/WTF/ChangeLog 2015-06-07 17:35:12 UTC (rev 185302)
+++ trunk/Source/WTF/ChangeLog 2015-06-07 17:37:37 UTC (rev 185303)
@@ -1,14 +1,3 @@
-2015-06-07 Dan Bernstein <[email protected]>
-
- Unifiy the definition of UNREACHABLE_FOR_PLATFORM
- https://bugs.webkit.org/show_bug.cgi?id=145737
-
- Reviewed by Anders Carlsson.
-
- * wtf/Assertions.h:
- (UNREACHABLE_FOR_PLATFORM): Use the macro for clang as well. Its expansion includes
- __attribute((__noreturn__)) so the pragmas are unnecessary.
-
2015-06-05 Chris Dumez <[email protected]>
[WK2][iOS] Limit the number of vnodes used by the WebContent processes
Modified: trunk/Source/WTF/wtf/Assertions.h (185302 => 185303)
--- trunk/Source/WTF/wtf/Assertions.h 2015-06-07 17:35:12 UTC (rev 185302)
+++ trunk/Source/WTF/wtf/Assertions.h 2015-06-07 17:37:37 UTC (rev 185303)
@@ -372,6 +372,19 @@
/* UNREACHABLE_FOR_PLATFORM */
+#if COMPILER(CLANG)
+// This would be a macro except that its use of #pragma works best around
+// a function. Hence it uses macro naming convention.
+#pragma clang diagnostic push
+#pragma clang diagnostic ignored "-Wmissing-noreturn"
+static inline void UNREACHABLE_FOR_PLATFORM()
+{
+ RELEASE_ASSERT_NOT_REACHED();
+}
+#pragma clang diagnostic pop
+#else
#define UNREACHABLE_FOR_PLATFORM() RELEASE_ASSERT_NOT_REACHED()
+#endif
+
#endif /* WTF_Assertions_h */
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes