Title: [188834] trunk/Tools
- Revision
- 188834
- Author
- [email protected]
- Date
- 2015-08-23 03:35:19 -0700 (Sun, 23 Aug 2015)
Log Message
Remove style checking rule regarding OwnPtr and PassOwnPtr
https://bugs.webkit.org/show_bug.cgi?id=148360
Reviewed by Darin Adler.
OwnPtr and PassOwnPtr were totally removed though, style rule is still alive.
Removed it.
* Scripts/do-webcore-rename:
* Scripts/webkitpy/style/checkers/cpp_unittest.py:
(PassPtrTest.test_pass_own_ptr_in_function): Deleted.
(PassPtrTest.test_pass_ref_ptr_return_value): Deleted.
(PassPtrTest.test_own_ptr_parameter_value): Deleted.
(WebKitStyleTest.test_names): Deleted.
Modified Paths
Diff
Modified: trunk/Tools/ChangeLog (188833 => 188834)
--- trunk/Tools/ChangeLog 2015-08-23 04:14:44 UTC (rev 188833)
+++ trunk/Tools/ChangeLog 2015-08-23 10:35:19 UTC (rev 188834)
@@ -1,3 +1,20 @@
+2015-08-23 Gyuyoung Kim <[email protected]>
+
+ Remove style checking rule regarding OwnPtr and PassOwnPtr
+ https://bugs.webkit.org/show_bug.cgi?id=148360
+
+ Reviewed by Darin Adler.
+
+ OwnPtr and PassOwnPtr were totally removed though, style rule is still alive.
+ Removed it.
+
+ * Scripts/do-webcore-rename:
+ * Scripts/webkitpy/style/checkers/cpp_unittest.py:
+ (PassPtrTest.test_pass_own_ptr_in_function): Deleted.
+ (PassPtrTest.test_pass_ref_ptr_return_value): Deleted.
+ (PassPtrTest.test_own_ptr_parameter_value): Deleted.
+ (WebKitStyleTest.test_names): Deleted.
+
2015-08-22 Timothy Horton <[email protected]>
WebKitTestRunner should use WKWebView on OS X and iOS
Modified: trunk/Tools/Scripts/do-webcore-rename (188833 => 188834)
--- trunk/Tools/Scripts/do-webcore-rename 2015-08-23 04:14:44 UTC (rev 188833)
+++ trunk/Tools/Scripts/do-webcore-rename 2015-08-23 10:35:19 UTC (rev 188834)
@@ -103,8 +103,6 @@
my %renamesContemplatedForTheFuture = (
"PassRefPtr" => "DeprecatedPassRefPtr",
- "OwnPtr" => "DeprecatedOwnPtr",
- "PassOwnPtr" => "DeprecatedPassOwnPtr",
"HTMLPlugInImageElement" => "HTMLEmbeddedObjectElement",
"isPlugInImageElement" => "isEmbeddedObjectElement",
Modified: trunk/Tools/Scripts/webkitpy/style/checkers/cpp_unittest.py (188833 => 188834)
--- trunk/Tools/Scripts/webkitpy/style/checkers/cpp_unittest.py 2015-08-23 04:14:44 UTC (rev 188833)
+++ trunk/Tools/Scripts/webkitpy/style/checkers/cpp_unittest.py 2015-08-23 10:35:19 UTC (rev 188834)
@@ -3639,15 +3639,6 @@
'Local variables should never be PassRefPtr (see '
'http://webkit.org/coding/RefPtr.html). [readability/pass_ptr] [5]')
- def test_pass_own_ptr_in_function(self):
- self.assert_pass_ptr_check(
- 'int myFunction()\n'
- '{\n'
- ' PassOwnPtr<Type1> variable = variable2;\n'
- '}',
- 'Local variables should never be PassOwnPtr (see '
- 'http://webkit.org/coding/RefPtr.html). [readability/pass_ptr] [5]')
-
def test_pass_other_type_ptr_in_function(self):
self.assert_pass_ptr_check(
'int myFunction()\n'
@@ -3673,18 +3664,10 @@
'PassRefPtr<Type1> myFunction();\n',
'')
self.assert_pass_ptr_check(
- 'OwnRefPtr<Type1> myFunction();\n',
- '')
- self.assert_pass_ptr_check(
'RefPtr<Type1> myFunction(int)\n'
'{\n'
'}',
'')
- self.assert_pass_ptr_check(
- 'OwnPtr<Type1> myFunction(int)\n'
- '{\n'
- '}',
- '')
def test_ref_ptr_parameter_value(self):
self.assert_pass_ptr_check(
@@ -3708,23 +3691,6 @@
'}',
'')
- def test_own_ptr_parameter_value(self):
- self.assert_pass_ptr_check(
- 'int myFunction(PassOwnPtr<Type1>)\n'
- '{\n'
- '}',
- '')
- self.assert_pass_ptr_check(
- 'int myFunction(OwnPtr<Type1>)\n'
- '{\n'
- '}',
- '')
- self.assert_pass_ptr_check(
- 'int myFunction(OwnPtr<Type1>& simple)\n'
- '{\n'
- '}',
- '')
-
def test_ref_ptr_member_variable(self):
self.assert_pass_ptr_check(
'class Foo {'
@@ -5100,12 +5066,6 @@
self.assert_lint('unsigned _fillRule : 1;',
'_fillRule' + name_underscore_error_message)
- # new operators in initialization.
- self.assert_lint('OwnPtr<uint32_t> variable(new uint32_t);', '')
- self.assert_lint('OwnPtr<uint32_t> variable(new (expr) uint32_t);', '')
- self.assert_lint('OwnPtr<uint32_t> under_score(new uint32_t);',
- 'under_score' + name_underscore_error_message)
-
def test_parameter_names(self):
# Leave meaningless variable names out of function declarations.
meaningless_variable_name_error_message = 'The parameter name "%s" adds no information, so it should be removed. [readability/parameter_name] [5]'
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes