On Jun 14, 2008, at 10:39 PM, Darin Adler wrote:

> On Jun 14, 2008, at 10:36 PM, Maciej Stachowiak wrote:
>
>> I would prefer if we keep a JS prefix only on the objects that seem  
>> like very generic names otherwise.
>
> Makes sense.
>
> Given that rule of thumb, what do you think of these:
>
>    "GetterSetterImp" => "JSGetterSetter",

Not sure this needs the prefix - this probably would not come up in  
other contexts.

>
>    "NumberImp" => "JSNumberCell",

Doesn't really need the prefix (Cell won't conflict) but it would be  
good to keep in sync with JSNumber so yes.

>    "StringImp" => "JSString",

Yes.

>    "ArrayInstance" => "JSArray",
>    "FunctionImp" => "JSFunction",

Both Array and Function seem like they could have lots of uses.

>
>
> Do all of those deserve the JS prefix? Maybe the first three and not  
> the last two?
>
>> Another thought that came up is that perhaps we should change our  
>> namespace from KJS to JSC.
>
> I like the idea. But I'm not crazy about the three WebKit namespaces  
> being WTF, JSC, and WebCore. One of these things is not like the  
> others!

Should the WebCore namespace be WC? That somehow seems less tasty than  
the others.

Regards,
Maciej

_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

Reply via email to