Hi all,

Thanks for the feedback.

I submitted a coding style update proposal at Bug 141040 
<https://bugs.webkit.org/show_bug.cgi?id=141040>.
Based on the mailing list feedback, the proposal is to use a static member 
function named "singleton()”.

I will also upload a patch to align our existing code unless there is any 
objection.

Kr,
--
Chris Dumez - Apple Inc.
Cupertino, CA




> On Jan 28, 2015, at 9:26 PM, Ryosuke Niwa <rn...@webkit.org> wrote:
> 
> On Wed, Jan 28, 2015 at 9:19 PM, Maciej Stachowiak <m...@apple.com 
> <mailto:m...@apple.com>> wrote:
> 
> This may be a question of what jargon we’ve encountered, but to me, 
> “singleton" clearly means "the one unique instance of this class" while 
> “instance" means "any instance of this class". If I hadn’t seen this thread, 
> I would interpret Class::instance() to mean “create a brand new instance of 
> this class” rather than “return the unique singleton instance of this class, 
> creating if necessary".
> 
> Agreed.  I also prefer Class::singleton() over Class::instance().
> 
> - R. Niwa
> _______________________________________________
> webkit-dev mailing list
> webkit-dev@lists.webkit.org
> https://lists.webkit.org/mailman/listinfo/webkit-dev

_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev

Reply via email to