It’s weird that we have ENABLE(ACCESSIBILITY) and HAVE(ACCESSIBILITY) so at the very least one of these should go away, probably HAVE.
Currently there are actual implementations for iOS, Mac, Windows, and ATK. The WPE implementation is just a stub with everything notImplemented. I did some work to make the WPE implementation just be the default at https://bugs.webkit.org/show_bug.cgi?id=190608 but it broke a build so I rolled it out and haven’t returned to it yet so this is good timing for the discussion as that’ll influence what needs to be done with that. If a stub implementation is ok for ports without an actual accessibility implementation then I’d say remove both flags. Then downstream users would never have to worry about breaking due to AX signatures changing. If not my vote is to just have ENABLE(ACCESSIBILITY) since it can then be toggled on and off with webkit-build. A company like Tesla could always provide a buildbot that turns off accessibility on a public port if this is a real pain point since all public ports have it enabled. - Don From: webkit-dev <webkit-dev-boun...@lists.webkit.org> On Behalf Of Timothy Hatcher Sent: Wednesday, November 14, 2018 7:06 PM To: Ryosuke Niwa <rn...@webkit.org> Cc: WebKit Development <firstname.lastname@example.org> Subject: Re: [webkit-dev] Remove HAVE_ACCESSIBILITY It wasn’t added for Tesla. But they did build with it disabled at the time I lasted worked on it. It was a frequent pain point to keep the build working when AX changes happened. — Timothy Hatcher On Nov 14, 2018, at 5:29 PM, Ryosuke Niwa <rn...@webkit.org<mailto:rn...@webkit.org>> wrote: I think it was added for Telsa's private port. Probably not worth maintaining the flag if the maintenance cost is high but is it? - R. Niwa On Wed, Nov 14, 2018 at 5:19 PM Fujii Hironori <fujii.hiron...@gmail.com<mailto:fujii.hiron...@gmail.com>> wrote: Hi webkit-dev, It seems that all port defines HAVE_ACCESSIBILITY=1. Can I remove all code for !HAVE(ACCESSIBILITY)? https://trac.webkit.org/browser/webkit/trunk/Source/WTF/wtf/Platform.h?rev=237992#L648 #if PLATFORM(COCOA) || PLATFORM(WIN) || PLATFORM(GTK) || PLATFORM(WPE) #define HAVE_ACCESSIBILITY 1 #endif Bug 21802 – Rename HAVE_ACCESSIBILITY to ENABLE_ACCESSIBILITY https://bugs.webkit.org/show_bug.cgi?id=21802 -- Fujii _______________________________________________ webkit-dev mailing list email@example.com<mailto:firstname.lastname@example.org> https://lists.webkit.org/mailman/listinfo/webkit-dev _______________________________________________ webkit-dev mailing list email@example.com<mailto:firstname.lastname@example.org> https://lists.webkit.org/mailman/listinfo/webkit-dev
_______________________________________________ webkit-dev mailing list email@example.com https://lists.webkit.org/mailman/listinfo/webkit-dev