On Sat, Nov 17, 2018 at 3:45 AM Ryosuke Niwa <rn...@webkit.org> wrote:

> I think the right macro to use here would have HAVE(ACCESSIBILITY). It
> never makes sense to compile out accessibility support if you have the
> support in a given platform/port. The question is really whether a given
> port / platform has the support for accessibility or not.
>
>
Thank you for the feedback.
Let's keep HAVE_ACCESSIBILITY macro.

Can I remove ENABLE_ACCESSIBILITY CMake variable?
It is used only in WebKitTestRunner.


https://github.com/WebKit/webkit/blob/dea6e0141a5df7b678221d4a474b5846176a913d/Tools/WebKitTestRunner/CMakeLists.txt#L76

Do you want to keep this condition by renaming it to HAVE_ACCESSIBILITY
CMake variable?

> if (HAVE_ACCESSIBILITY)

We can not keep this code by using platform variable, for example
WTF_PLATFORM_WIN_CAIRO, because no port is using the code.

> if (WTF_PLATFORM_WIN_CAIRO)

Or, keep it by doing following?

> if (FALSE)

Bug 191831 – [CMake] Remove ENABLE_ACCESSIBILITY CMake variable
https://bugs.webkit.org/show_bug.cgi?id=191831
_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev

Reply via email to