On Thu, Apr 9, 2020 at 11:49 am, Alexey Proskuryakov <a...@webkit.org> wrote:

The license is not BSD or LGPL, so that's one aspect to consider.

Why exactly are distros unwilling to update ICU?

- Alexey

Distros would upgrade to newer minor releases of the library, but updating system packages to new major versions is not allowed in most stable distros.

Sometimes distros make exceptions (e.g. for WebKitGTK, which is special due to very high number of CVEs), but ICU does not warrant an exception. There are probably hundreds of applications using ICU in distros, if not more. Who knows what might break!


_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev

Reply via email to