Hi Mark,

On 6 Sep 2016, at 10:04 PM, Mark Wardle <m...@wardle.org> wrote:

> It isn’t quite right from eclipse. I can run a newly created application from 
> within eclipse, but when I try to run a migrated application, I get this 
> error:
> 
> <main> java.lang.ExceptionInInitializerError
>       at 
> com.webobjects.appserver.WOResourceManager.__getJavaWebObjectsResourceAsStream(WOResourceManager.java:116)
>       at 
> com.webobjects.appserver._private.WOProperties.initUserDefaultsKeys(WOProperties.java:317)
>       at 
> com.webobjects.appserver.WOApplication._initWOApp(WOApplication.java:5743)
>       at com.webobjects.appserver.WOApplication.<init>(WOApplication.java:779)
>       at 
> er.extensions.appserver.ajax.ERXAjaxApplication.<init>(ERXAjaxApplication.java:30)
>       at 
> er.extensions.appserver.ERXApplication.<init>(ERXApplication.java:1135)
>       at com.eldrix.news.app.Application.<init>(Application.java:66)
>       at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
>       at 
> sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
>       at 
> sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
>       at java.lang.reflect.Constructor.newInstance(Constructor.java:408)
>       at java.lang.Class.newInstance(Class.java:438)
>       at com.webobjects.appserver.WOApplication.main(WOApplication.java:547)
>       at er.extensions.appserver.ERXApplication.main(ERXApplication.java:890)
>       at com.eldrix.news.app.Application.main(Application.java:63)
> Caused by: java.lang.NullPointerException
>       at 
> er.extensions.appserver.ERXApplication$Loader.collectMainProps(ERXApplication.java:757)
>       at 
> er.extensions.appserver.ERXApplication$Loader.bundleDidLoad(ERXApplication.java:682)
>       at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
>       at 
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
>       at java.lang.reflect.Method.invoke(Method.java:483)
>       at 
> com.webobjects.foundation.NSSelector._safeInvokeMethod(NSSelector.java:122)
>       at 
> com.webobjects.foundation.NSNotificationCenter$_Entry.invokeMethod(NSNotificationCenter.java:588)
>       at 
> com.webobjects.foundation.NSNotificationCenter.postNotification(NSNotificationCenter.java:532)
>       at 
> com.webobjects.foundation.NSNotificationCenter.postNotification(NSNotificationCenter.java:562)
>       at 
> com.webobjects.foundation.NSBundle.postNotification(NSBundle.java:2546)
>       at 
> com.webobjects.foundation.NSBundle.LoadBundlesFromJars(NSBundle.java:735)
>       at com.webobjects.foundation.NSBundle.<clinit>(NSBundle.java:345)
>       ... 15 more
> 
> java.lang.NullPointerException
>       at 
> er.extensions.appserver.ERXShutdownHook$1.run(ERXShutdownHook.java:64)

I just hit this exact issue. You know what it turned out to be? Stale 
patternsets under woproject—I was migrating a Fluffy Bunny project, and forgot 
that step. Fixed the patternsets, fixed the NPE.


-- 
Paul Hoadley
http://logicsquad.net/



 _______________________________________________
Do not post admin requests to the list. They will be ignored.
Webobjects-dev mailing list      (Webobjects-dev@lists.apple.com)
Help/Unsubscribe/Update your Subscription:
https://lists.apple.com/mailman/options/webobjects-dev/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to