I was finally able to get a clean VM of El Capitan installed on my Mac and
tried installing WeeWX on it.

I installed pip using

sudo easy_install pip


I was able to install the following without any problems:

sudo pip install Pillow  (installed into
/Library/Python/2.7/site-packages/PIL)
sudo pip install configobj
sudo pip install Cheetah
sudo pip install pyserial
sudo pip install pyusb


However, these two failed due to the lack of a compiler.

sudo pip install pysqlite - failed
sudo pip install pyephem - failed


Installing xcode on a VM required bringing up a GUI, signing into
developer.apple.com, then, from the command line, running

xcode-select --install


Once I got all that done, I was able to install pyephem

sudo pip install pyephem


but installing pysqlite failed again because of write permissions to
/System/Library/Frameworks/Python.framework/Versions/2.7/pysqlite2-doc, so
I used pip to install as myself:

pip install --user pysqlite


which worked fine.

I downloaded the weewx tarball, expanded it, then edited setup.cfg. Then
ran setup.py, choosing the simulator.

WeeWX came up fine. The only problem was that Cheetah did not have the "C"
version of its NameMapper utility, so it substituted its Python version,
which can be painfully slow. This probably happened because I installed
Cheetah *before* I installed xcode, so it did the best without a compiler.
If you already have xcode installed, I doubt you would see this.

-tk








On Mon, Mar 5, 2018 at 7:52 AM, Thomas Keffer <tkef...@gmail.com> wrote:

> Well, I'm sorry to hear that the Mac prefers easy_install. These days,
> it's pretty old school, having been replaced by pip. But, be that as it
> may..
>
> I don't know why easy_install is trying to install pysqlite into
> /Users/Shared/weewx/bin. Perhaps because you have PYTHONPATH defined? Try
> removing it as an environment variable, then installing. As I said earlier,
> it is not needed to run weewx.
>
> This is a long shot, but another possibility is that easy_install is
> seeing the file setup.cfg, which contains a definition for home. Try cd'ing
> to a different directory, then trying the install.
>
> -tk
>
> On Mon, Mar 5, 2018 at 6:59 AM, David Barto <kdba...@gmail.com> wrote:
>
>>
>>
>> On Monday, March 5, 2018 at 6:18:26 AM UTC-8, mwall wrote:
>>>
>>> On Saturday, March 3, 2018 at 6:43:19 PM UTC-5, Tom Keffer wrote:
>>>>
>>>> Nice to have a Mac expert around! Perhaps in a quiet moment you can
>>>> tell me how to get the system logger to work on High Sierra.
>>>>
>>>
>>> yes, please, i would like some of that magic too!
>>>
>>> I'll be more than happy to help out on this kind of thing. When I have
>> free time. That isn't looking likely in the near future as the product was
>> supposed to ship on Feb 28, and it is now Feb 33rd and I'm still not
>> complete with my part.
>>
>>
>
>

Reply via email to