wunderfixer could be used to fill in the missing data at wunderground


On Saturday, 24 February 2018 08:04:08 UTC+2, ddu...@gmail.com wrote:

> Every time my logger gets a lot of data that hasn't been sent to weewx 
> because system is offline (like power outage for last 2 days), the system 
> comes up, vantage driver fails a CRC16 error well documented and then the 
> only thing you can do is manually pull all the power to the envoy and 
> restart weewx.  it will download some data to the database and then get an 
> error again and exit the vantage driver.  You may get and hour or 2 of data 
> and then have to stop, pull power, start weewx and view log.
>
>
> I used to have the data being pumped to CWOP and WUNDERGROUND.  I turned 
> off CWOP and it behaved slightly better but it seems as soon as a 
> WUNDERGROUND record went out it would stop working pretty close to that 
> point.
>
> Today I decided to do a wee_device --dump.  I'm confused why using the 
> exact same drivers it has no problem reading and streaming all the data in 
> to the database (obviously error-ing out on duplicate keys) and never gets 
> a CRC error.    Obviously no WUNDERGROUND data is sent but the process does 
> finish. If I then start weewx, it goes right in to the loop process and 
> doesn't fail.
>
> I know people have chased the USB cable, power supply (my logger is 
> wrapped in AC duct foil tape (including the cable) and has a 2 ferrite 
> ended cable.  Doesn't help. Power supply is new and fine on Rpi.   
>
> I think it may be the vantage driver and trying to pause during a push to 
> one of the services while downloading all this data.  Can't prove that  but 
> that is my observation. 
>
> I modified vantage.py  today to allow me to not have to say yes to the 
> dump command with a --dumpauto option. I took weewx out of rc.d and run a 
> job a startup using cron that calls wee_device --dumpauto and then 
> immediately starts weewx.  
>
> While that is the backstory, what am I missing by taking this approach 
> that at least has the system back up and running when the power goes down 
> or multiple hours of data end up on the logger without weewx running?
>
> I get I am probably not getting data to wunderground for all those  
> periods.  it is in the database.  not sure what else to try.
>
>

-- 
You received this message because you are subscribed to the Google Groups 
"weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to weewx-user+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to