I normally run weewx with a vantage and a few 1 wire sensors

standardreport units are set to metric

but the target units in weewx.conf set to US
    target_unit = US    # Options are 'US', 'METRICWX', or 'METRIC'

all temperatures and other readings displayed on the html pages as they 
should be

I have tried to create my own extension to read my electricity meter and it 
should work (this version is in simulator mode just now) 

the current sensor collects the power and temp readings to a txt file and 
my extension imports it in to weewx.sdb
the imported power readings are in watts however the temperature is in C'

Checking the weewxsdb all the temp readings are stored in F and then 
displayed on the html pages in C'

this particular reading cctemp is being parsed and stored in weewx.sdb as 
deg C so when its shown on the html pages its incorrect  

i have tried to convert it back to 'C under stdcalibrate/corrections but it 
has no effect?

is it possible to display this temperature back to 'C

Unit conversion options 

The tag optional_unit_conversion can be used with either current 
observations or aggregations. If supplied, the results will be converted to 
the specified units. For example, if you have set group_pressure to inches 
of mercury (inHg), then the tag 

Today's average pressure=$day.barometer.avg 

would normally give a result such as

Today's average pressure=30.05 inHg 

However, if you add mbar to the end, 


then the results will be in millibars:

i have tried to convert with the above but unsure how to implement it

thanks for any advice

You received this message because you are subscribed to the Google Groups 
"weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to weewx-user+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to