On Thu, 18 Feb 2010 23:06:12 +0100, Jonas Sicking <[email protected]> wrote:
On Wed, Feb 17, 2010 at 11:30 PM, Anne van Kesteren <[email protected]> wrote:
On Thu, 18 Feb 2010 00:15:25 +0100, Jonas Sicking <[email protected]> wrote:

So I suggest we add a method like

interface HTMLFormElement : HTMLElement {
 ...
 FormData getFormData();
 ...
};

Should we name it toFormData() instead for consistency with <canvas>? Or is
<canvas> inconsistent with something else?

There are much more functions that are named "getX" than "toX" in the
DOM. Such as getElementById, getElementsByTagName,
getBoundingClientRect.

Sure, but this seems more analogous to toDataURL() than to getElementById(). YMMV.


--
Anne van Kesteren
http://annevankesteren.nl/

Reply via email to