*ahem*. 'polymorphy' that is...

Eelco Hillenius wrote:

Wouldn't it be a good idea to rename Component.addAttributeModifier(final ComponentTagAttributeModifier modifier) to Component.add(final ComponentTagAttributeModifier modifier), so that it confirms to other adds like FormComponent.add(final IValidator validator)?

In other words, do we agree on the rule to use add instead of addXXX and set instead of setXXX and thus using polyphormy instead of naming?

Eelco


-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. http://productguide.itmanagersjournal.com/
_______________________________________________
Wicket-develop mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/wicket-develop




-------------------------------------------------------
SF email is sponsored by - The IT Product Guide
Read honest & candid reviews on hundreds of IT Products from real users.
Discover which products truly live up to the hype. Start reading now. http://productguide.itmanagersjournal.com/
_______________________________________________
Wicket-develop mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/wicket-develop

Reply via email to