one more little thing... autolink resolver now contains some old hardwired stuff (line 202-210 of AutolinkComponentNameResolver)
if (!command.equals("children") && !command.equals("border"))
{
markupStream.throwMarkupException(
"Special component names include [border], [body] and [autolink], "
+ "but not '" + command + "'");
}
this exception will be thrown if no resolver is found for the name, right?
much more elegant. so this case should be removed.
was wondering... do you like ComponentResolver better than ComponentNameResolver? i'm not sure the name part really adds anything... it's resolving the name in some sense, but the real purpose is to resolve the component for the tag.
Juergen Donnerstag wrote:
if this does work generically,
just try it. I send you all the sources
although we will want to continue to debate how much and/or how to open
up our namespaces to users...
I didn't meant to stop the <wicket> discussion at all.
one thought: wouldn't it be better to call it Container.resolveComponentName()?
also, if ComponentNameResolver is an interface, it should be IComponentNameResolver in wicket style.
sure
Juergen
------------------------------------------------------- The SF.Net email is sponsored by: Beat the post-holiday blues Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek. It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt _______________________________________________ Wicket-develop mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/wicket-develop
------------------------------------------------------- The SF.Net email is sponsored by: Beat the post-holiday blues Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek. It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt _______________________________________________ Wicket-develop mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/wicket-develop
